aboutsummaryrefslogtreecommitdiffstats
path: root/www/dansguardian/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-08 20:57:43 +0800
committerpav <pav@FreeBSD.org>2006-04-08 20:57:43 +0800
commita6ba91736ef1a495a06862a6e672355cd82e3fdc (patch)
tree68ed66fd111bda449017d926a3e7072f04d90855 /www/dansguardian/Makefile
parentb4383c2dabdda22c27f0ec3c86a34b47455b1ba7 (diff)
downloadfreebsd-ports-gnome-a6ba91736ef1a495a06862a6e672355cd82e3fdc.tar.gz
freebsd-ports-gnome-a6ba91736ef1a495a06862a6e672355cd82e3fdc.tar.zst
freebsd-ports-gnome-a6ba91736ef1a495a06862a6e672355cd82e3fdc.zip
- Better use of rc_subr framework
- Updated startup script - Fixed pkg-plist PR: ports/94802 Submitted by: Freddie Cash <fcash@sd73.bc.ca> (maintainer)
Diffstat (limited to 'www/dansguardian/Makefile')
-rw-r--r--www/dansguardian/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index bb61dc7e57fb..f3332c007dc4 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dansguardian
PORTVERSION= 2.8.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= # empty, see below
DISTNAME= ${PORTNAME}-${PORTVERSION}.source
@@ -17,8 +17,7 @@ COMMENT= A fast, feature-rich web content filter for Squid proxy servers
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-USE_RC_SUBR= yes
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+USE_RC_SUBR= dansguardian.sh
CONFLICTS= dansguardian-2.[67]*
LATEST_LINK= dansguardian
@@ -36,15 +35,15 @@ CONFIGURE_ARGS= --bindir=/sbin/ \
MAN8= dansguardian.8
NOMANCOMPRESSED= yes
-OPTIONS= DG_APACHE "Enable Apache support." on \
+OPTIONS= DG_APACHE "Enable Apache support for access denied page" on \
DG_PHRASELISTS "Install new phraselists over the old ones." off
DG_URL= http://dansguardian.org/index.php?page=copyright2
CONFDIR= ${PREFIX}/etc/dansguardian
-NO_CDROM= "Commercial download is restricted. Check ${DG_URL} for more info"
-NO_PACKAGE= "Redistribution is restricted. Check ${DG_URL} for more info"
-RESTRICTED= "${NO_PACKAGE}"
+NO_CDROM= Commercial download is restricted. Check ${DG_URL} for more info
+NO_PACKAGE= Redistribution is restricted. Check ${DG_URL} for more info
+RESTRICTED= ${NO_PACKAGE}
.include <bsd.port.pre.mk>
@@ -64,10 +63,6 @@ USE_APACHE= 1.3+
IGNORE="Commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make"
.endif
-post-extract:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/dansguardian.sh > ${WRKSRC}/dansguardian.sh
-
pre-install:
# Configure pkg-plist based on whether phraselists are to be installed or not
.if defined(WITH_DG_PHRASELISTS)
@@ -86,8 +81,8 @@ post-install:
.endif
# Install startup script
- @${ECHO_MSG} "===> Installing startup script into ${PREFIX}/etc/rc.d"
- @${INSTALL_SCRIPT} ${WRKSRC}/dansguardian.sh ${PREFIX}/etc/rc.d/start-dg.sh
+# @${ECHO_MSG} "===> Installing startup script into ${PREFIX}/etc/rc.d"
+# @${INSTALL_SCRIPT} ${WRKSRC}/dansguardian.sh ${PREFIX}/etc/rc.d/start-dg.sh
# Display post-install message
@${CAT} pkg-message