aboutsummaryrefslogtreecommitdiffstats
path: root/www/dillo-i18n
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-06-03 10:01:42 +0800
committermnag <mnag@FreeBSD.org>2006-06-03 10:01:42 +0800
commitf465f2e9826fa8bdd75a8d73ee9bede7d86b5ce1 (patch)
treebf65e82fc95afe309269c463a806e244ecfc5e4c /www/dillo-i18n
parentf0f8c3b19c4ff2c6d6f23897c8d9e52ad5e0cefb (diff)
downloadfreebsd-ports-gnome-f465f2e9826fa8bdd75a8d73ee9bede7d86b5ce1.tar.gz
freebsd-ports-gnome-f465f2e9826fa8bdd75a8d73ee9bede7d86b5ce1.tar.zst
freebsd-ports-gnome-f465f2e9826fa8bdd75a8d73ee9bede7d86b5ce1.zip
- Add kbob to enable dlgui. WITH_DILLO_DLGUI
PR: 98143 Submitted by: maintainer
Diffstat (limited to 'www/dillo-i18n')
-rw-r--r--www/dillo-i18n/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/www/dillo-i18n/Makefile b/www/dillo-i18n/Makefile
index 11be37f306e5..df7441cd73fd 100644
--- a/www/dillo-i18n/Makefile
+++ b/www/dillo-i18n/Makefile
@@ -9,6 +9,8 @@
# WITH_DILLO_META-REFRESH: make dillo accept the meta-refresh tag
# WITHOUT_DILLO_TABS: disable support for tabbed browsing
# WITHOUT_DILLO_ANTIALIAS: disable support for antialiased display
+# WITH_DILLO_DLGUI: enable experimental FLTK2 based gui for file
+# downloads
#
# TODO:
# SSL support is currently partly broken in this version of the i18n dillo:
@@ -41,7 +43,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-cookies --enable-ipv6 --enable-threaded-dns \
- --disable-dlgui \
--libdir=${PREFIX}/libexec
CONFLICTS= dillo-[0-9].[0-9].[0-9]*
@@ -83,6 +84,15 @@ CONFIGURE_ARGS+= --enable-anti-alias
CONFIGURE_ARGS+= --disable-anti-alias
.endif
+.if defined(WITH_DILLO_DLGUI)
+CONFIGURE_ARGS+= --enable-dlgui
+BUILD_DEPENDS+= fltk>=2.0.r4825:${PORTSDIR}/x11-toolkits/fltk2
+CPPFLAGS+= -I${X11BASE}/include
+LDFLAGS+= -L${X11BASE}/lib
+.else
+CONFIGURE_ARGS+= --disable-dlgui
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
s|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' ${WRKSRC}/configure
@@ -110,6 +120,12 @@ pre-configure:
@${ECHO_CMD} " Set WITHOUT_DILLO_ANTIALIAS=yes in your make environment or on the"
@${ECHO_CMD} " commandline to disable support for antialiased fonts."
.endif
+.if !defined(WITH_DILLO_DLGUI)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " Set WITH_DILLO_DLGUI=yes in your make environment or on the"
+ @${ECHO_CMD} " commandline to enable a FLTK2 based gui for download operations."
+.endif
+
@${ECHO_CMD} ""
.include <bsd.port.mk>