aboutsummaryrefslogtreecommitdiffstats
path: root/www/drupal7/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-16 19:01:39 +0800
committerpav <pav@FreeBSD.org>2005-07-16 19:01:39 +0800
commit40b3bde11d62482d313314b48f1a32e0807b3898 (patch)
tree17ee0325720dd7ebde736219406a09ff97ff2ab0 /www/drupal7/Makefile
parent9bfb04e40ac2fc3adfbf436230d499622a550447 (diff)
downloadfreebsd-ports-gnome-40b3bde11d62482d313314b48f1a32e0807b3898.tar.gz
freebsd-ports-gnome-40b3bde11d62482d313314b48f1a32e0807b3898.tar.zst
freebsd-ports-gnome-40b3bde11d62482d313314b48f1a32e0807b3898.zip
- Update to 4.6.2, which fixes major security problem
PR: ports/83087 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru> Approved by: maintainer timeout (9 days, rushed for security reasons) Security: CAN-2005-1921, CAN-2005-2106 http://secunia.com/advisories/15872/
Diffstat (limited to 'www/drupal7/Makefile')
-rw-r--r--www/drupal7/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/drupal7/Makefile b/www/drupal7/Makefile
index bb38519b5cc0..afd3be1e8652 100644
--- a/www/drupal7/Makefile
+++ b/www/drupal7/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= drupal
-PORTVERSION= 4.6.0
+PORTVERSION= 4.6.2
CATEGORIES= www
MASTER_SITES= http://drupal.org/files/projects/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -23,9 +23,9 @@ RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
NO_BUILD= yes
DRUPDIR= www/data/drupal
DOCS= CHANGELOG.txt INSTALL.txt LICENSE.txt MAINTAINERS.txt
+PLIST_SUB+= DRUPDIR=${DRUPDIR}
do-install:
-
${MKDIR} ${PREFIX}/${DRUPDIR}
${CP} ${WRKSRC}/.htaccess ${PREFIX}/${DRUPDIR}
${CP} ${WRKSRC}/cron.php ${PREFIX}/${DRUPDIR}
@@ -40,10 +40,12 @@ do-install:
${CP} -R ${WRKSRC}/themes ${PREFIX}/${DRUPDIR}
${CP} ${WRKSRC}/update.php ${PREFIX}/${DRUPDIR}
${CP} ${WRKSRC}/xmlrpc.php ${PREFIX}/${DRUPDIR}
+.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/${DRUPDIR}/doc
.for FILE in ${DOCS}
${CP} ${WRKSRC}/${FILE} ${PREFIX}/${DRUPDIR}/doc
.endfor
+.endif
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${DRUPDIR}
@${ECHO_MSG} ""