aboutsummaryrefslogtreecommitdiffstats
path: root/www/dtse
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-30 02:05:44 +0800
committerpav <pav@FreeBSD.org>2004-03-30 02:05:44 +0800
commitc271fa0a9aea35a46a1063692e13b5ff4eaea50d (patch)
treeb69444bc5a027bbc42c74f1a5042c173a656ecf8 /www/dtse
parent98b9aa662e9f1f994d51480ca7ecbe470bed6077 (diff)
downloadfreebsd-ports-gnome-c271fa0a9aea35a46a1063692e13b5ff4eaea50d.tar.gz
freebsd-ports-gnome-c271fa0a9aea35a46a1063692e13b5ff4eaea50d.tar.zst
freebsd-ports-gnome-c271fa0a9aea35a46a1063692e13b5ff4eaea50d.zip
Douglas Thrift's Search Engine is an indexing search engine for use on small
websites such as personal or small business sites. It is designed to be very similar to Google for end users and its output is customizable. For indexing, it supports both the Robots Exclusion Protocol and the Robots META Tag as specified at http://www.robotstxt.org/wc/exclusion.html. WWW: http://computers.douglasthrift.net/searchengine/ PR: ports/64794 Submitted by: Douglas Thrift <douglas@douglasthrift.net>
Diffstat (limited to 'www/dtse')
-rw-r--r--www/dtse/Makefile39
-rw-r--r--www/dtse/distinfo2
-rw-r--r--www/dtse/pkg-descr10
-rw-r--r--www/dtse/pkg-plist17
4 files changed, 68 insertions, 0 deletions
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
new file mode 100644
index 000000000000..2c02ded017bb
--- /dev/null
+++ b/www/dtse/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dtse
+# Date created: 7 Mar 2004
+# Whom: Douglas Thrift <douglas@douglasthrift.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtse
+PORTVERSION= 1.2
+CATEGORIES= www perl5
+MASTER_SITES= http://computers.douglasthrift.net/searchengine/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= An indexing search engine for use on small websites
+
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
+USE_PERL5= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}/${PORTNAME}
+
+MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/dtse/distinfo b/www/dtse/distinfo
new file mode 100644
index 000000000000..e4e502ed8b67
--- /dev/null
+++ b/www/dtse/distinfo
@@ -0,0 +1,2 @@
+MD5 (dtse-1.2-src.tar.bz2) = b7f7570f4f3ef96b66bafc236c4d91cd
+SIZE (dtse-1.2-src.tar.bz2) = 84957
diff --git a/www/dtse/pkg-descr b/www/dtse/pkg-descr
new file mode 100644
index 000000000000..c0b9012273ae
--- /dev/null
+++ b/www/dtse/pkg-descr
@@ -0,0 +1,10 @@
+Douglas Thrift's Search Engine is an indexing search engine for use on small
+websites such as personal or small business sites. It is designed to be
+very similar to Google for end users and its output is customizable. For
+indexing, it supports both the Robots Exclusion Protocol and the Robots META
+Tag as specified at http://www.robotstxt.org/wc/exclusion.html.
+
+WWW: http://computers.douglasthrift.net/searchengine/
+
+- Douglas Thrift
+douglas@douglasthrift.net
diff --git a/www/dtse/pkg-plist b/www/dtse/pkg-plist
new file mode 100644
index 000000000000..5a4bd3b5f27b
--- /dev/null
+++ b/www/dtse/pkg-plist
@@ -0,0 +1,17 @@
+dtse/LICENSE
+dtse/LICENSE.html
+dtse/README
+dtse/README.html
+dtse/osi-certified-90x75.png
+dtse/bin/Search
+dtse/http/dtse_pb.png
+dtse/http/search.cgi
+dtse/data/header.html
+dtse/data/body.html
+dtse/data/footer.html
+dtse/data/notfound.html
+dtse/data/pages.html
+@dirrm dtse/bin
+@dirrm dtse/http
+@dirrm dtse/data
+@dirrm dtse