aboutsummaryrefslogtreecommitdiffstats
path: root/www/epiphany-extensions
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
committerkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
commit6a2a890c5cd397f9f0287409c2aa0244d50f3573 (patch)
treefc02bcba8bfa155b5cf452d6bafe1cb06aca4848 /www/epiphany-extensions
parent0e415a93a0424a4b284c88c39b19d93d80b66c8a (diff)
downloadfreebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.gz
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.zst
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Diffstat (limited to 'www/epiphany-extensions')
-rw-r--r--www/epiphany-extensions/Makefile20
-rw-r--r--www/epiphany-extensions/distinfo6
-rw-r--r--www/epiphany-extensions/pkg-descr13
-rw-r--r--www/epiphany-extensions/pkg-plist43
4 files changed, 52 insertions, 30 deletions
diff --git a/www/epiphany-extensions/Makefile b/www/epiphany-extensions/Makefile
index 3ad7badbc5a0..7eaf1e212ff9 100644
--- a/www/epiphany-extensions/Makefile
+++ b/www/epiphany-extensions/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/epiphany-extensions/Makefile,v 1.122 2009/10/19 02:40:50 kwm Exp $
+# $MCom: ports/www/epiphany-extensions/Makefile,v 1.125 2010/04/02 20:47:49 kwm Exp $
#
PORTNAME= epiphany-extensions
-PORTVERSION= 2.28.1
-PORTREVISION= 2
+PORTVERSION= 2.30.0
+PORTREVISION= 0
CATEGORIES= www gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,7 +18,7 @@ COMMENT= A set of add-ons for the Epiphany web browser
BUILD_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+ webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
USE_GETTEXT= yes
@@ -30,7 +30,7 @@ USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-EPHY_EXTENSIONS=all,rss
+EPHY_EXTENSIONS=really-all
EPHY_VERSION= ${PORTVERSION:R}
PLIST_SUB= VERSION=${EPHY_VERSION} EPHY_VERSION=${EPHY_VERSION}
@@ -41,15 +41,17 @@ OPTIONS= OPENSP "Enable OpenSP SGML support" off
.if defined(WITH_OPENSP)
CONFIGURE_ARGS+= --enable-opensp=yes
+LIB_DEPENDS+= osp.5:${PORTSDIR}/textproc/opensp
.else
CONFIGURE_ARGS+= --disable-opensp
.endif
CONFIGURE_ARGS+=--with-extensions="${EPHY_EXTENSIONS}"
-pre-everything::
- @${ECHO_MSG} "Epiphany-extensions also supports the following tunable option(s):"
- @${ECHO_MSG} " WITH_OPENSP=yes Enable support for OpenSP SGML validation"
- @${ECHO_MSG} ""
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$($$PKG_CONFIG --variable=extensionsdir epiphany-$$_epiphany_api_version)|${PREFIX}/lib/epiphany/${PORTVERSION:R}/extensions|g' \
+ -e 's|$$($$PKG_CONFIG --variable=icondir epiphany-$$EPIPHANY_API_VERSION)|${PREFIX}/share/epiphany/icons|g' \
+ -e 's|EPIPHANY_API_VERSION=2.29|EPIPHANY_API_VERSION=2.30|g' \
+ ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/www/epiphany-extensions/distinfo b/www/epiphany-extensions/distinfo
index 411231617165..1a621f598ba1 100644
--- a/www/epiphany-extensions/distinfo
+++ b/www/epiphany-extensions/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/epiphany-extensions-2.28.1.tar.bz2) = 565d32a8b94fd023f11a82dcef2bf634
-SHA256 (gnome2/epiphany-extensions-2.28.1.tar.bz2) = 0f14413316ebbdba392c9df7468d0d08811376ee26c735d7e523fc4eba44572a
-SIZE (gnome2/epiphany-extensions-2.28.1.tar.bz2) = 1389667
+MD5 (gnome2/epiphany-extensions-2.30.0.tar.bz2) = 76dd4f6296a259d09554e693336187a2
+SHA256 (gnome2/epiphany-extensions-2.30.0.tar.bz2) = cf2e7c8ea8cc34740d945ffa7b877dbe9f047b43f8609f6d78c6811ca69efe24
+SIZE (gnome2/epiphany-extensions-2.30.0.tar.bz2) = 1564058
diff --git a/www/epiphany-extensions/pkg-descr b/www/epiphany-extensions/pkg-descr
index 06c245526104..309ccdfa876b 100644
--- a/www/epiphany-extensions/pkg-descr
+++ b/www/epiphany-extensions/pkg-descr
@@ -1,9 +1,12 @@
Epiphany-extensions is a set of plugins for the Epiphany web browser that
-extend its base functionality. Currently, the following extensions are
-supported:
+extend its base functionality. Some of those extensions include:
-* Mouse gestures
-* Pop-up blocker
-* Tabs menu
+* Actions
+* Ad Blocker
+* Certificate Viewer
+* Greasemonkey
+* Mouse Gestures
+* Newsfeed extractor
+* and more...
WWW: http://www.gnome.org/projects/epiphany/extensions
diff --git a/www/epiphany-extensions/pkg-plist b/www/epiphany-extensions/pkg-plist
index e44956a16b5b..d0a28b1cabe2 100644
--- a/www/epiphany-extensions/pkg-plist
+++ b/www/epiphany-extensions/pkg-plist
@@ -5,6 +5,8 @@ lib/epiphany/%%VERSION%%/extensions/auto-scroller.ephy-extension
lib/epiphany/%%VERSION%%/extensions/certificates.ephy-extension
lib/epiphany/%%VERSION%%/extensions/extensions-manager-ui.ephy-extension
lib/epiphany/%%VERSION%%/extensions/gestures.ephy-extension
+lib/epiphany/%%VERSION%%/extensions/greasemonkey.ephy-extension
+lib/epiphany/%%VERSION%%/extensions/html5tube.ephy-extension
lib/epiphany/%%VERSION%%/extensions/libactionsextension.la
lib/epiphany/%%VERSION%%/extensions/libactionsextension.so
lib/epiphany/%%VERSION%%/extensions/libadblockextension.la
@@ -19,32 +21,41 @@ lib/epiphany/%%VERSION%%/extensions/libextensionsmanageruiextension.la
lib/epiphany/%%VERSION%%/extensions/libextensionsmanageruiextension.so
lib/epiphany/%%VERSION%%/extensions/libgesturesextension.la
lib/epiphany/%%VERSION%%/extensions/libgesturesextension.so
+lib/epiphany/%%VERSION%%/extensions/libgreasemonkeyextension.la
+lib/epiphany/%%VERSION%%/extensions/libgreasemonkeyextension.so
+lib/epiphany/%%VERSION%%/extensions/libhtml5tubeextension.la
+lib/epiphany/%%VERSION%%/extensions/libhtml5tubeextension.so
+lib/epiphany/%%VERSION%%/extensions/libpermissionsextension.la
+lib/epiphany/%%VERSION%%/extensions/libpermissionsextension.so
lib/epiphany/%%VERSION%%/extensions/libpushscrollerextension.la
lib/epiphany/%%VERSION%%/extensions/libpushscrollerextension.so
lib/epiphany/%%VERSION%%/extensions/librssextension.la
lib/epiphany/%%VERSION%%/extensions/librssextension.so
-lib/epiphany/%%VERSION%%/extensions/libsidebarextension.la
-lib/epiphany/%%VERSION%%/extensions/libsidebarextension.so
-lib/epiphany/%%VERSION%%/extensions/libsoupflyextension.so
+lib/epiphany/%%VERSION%%/extensions/libsampleextension.la
+lib/epiphany/%%VERSION%%/extensions/libsampleextension.so
lib/epiphany/%%VERSION%%/extensions/libsoupflyextension.la
+lib/epiphany/%%VERSION%%/extensions/libsoupflyextension.so
lib/epiphany/%%VERSION%%/extensions/libtabgroupsextension.la
lib/epiphany/%%VERSION%%/extensions/libtabgroupsextension.so
+lib/epiphany/%%VERSION%%/extensions/libtabkeytabnavigateextension.la
+lib/epiphany/%%VERSION%%/extensions/libtabkeytabnavigateextension.so
lib/epiphany/%%VERSION%%/extensions/libtabstatesextension.la
lib/epiphany/%%VERSION%%/extensions/libtabstatesextension.so
+lib/epiphany/%%VERSION%%/extensions/permissions.ephy-extension
lib/epiphany/%%VERSION%%/extensions/push-scroller.ephy-extension
lib/epiphany/%%VERSION%%/extensions/rss.ephy-extension
-lib/epiphany/%%VERSION%%/extensions/sidebar.ephy-extension
+lib/epiphany/%%VERSION%%/extensions/sample.ephy-extension
lib/epiphany/%%VERSION%%/extensions/soup-fly.ephy-extension
lib/epiphany/%%VERSION%%/extensions/tab-groups.ephy-extension
+lib/epiphany/%%VERSION%%/extensions/tab-key-tab-navigate.ephy-extension
lib/epiphany/%%VERSION%%/extensions/tab-states.ephy-extension
%%DATADIR%%/adblock-patterns
%%DATADIR%%/ephy-gestures.xml
-%%DATADIR%%/glade/action-properties.glade
-%%DATADIR%%/glade/actions-editor.glade
-%%DATADIR%%/glade/adblock.ui
-%%DATADIR%%/glade/extensions-manager-ui.ui
-%%DATADIR%%/glade/rss-ui.glade
-%%DATADIR%%/xml/epiphany-sidebar-ui.xml
+%%DATADIR%%/ui/action-properties.ui
+%%DATADIR%%/ui/actions-editor.ui
+%%DATADIR%%/ui/adblock.ui
+%%DATADIR%%/ui/extensions-manager-ui.ui
+%%DATADIR%%/ui/rss-ui.ui
share/epiphany/icons/hicolor/16x16/status/ad-blocked.png
share/epiphany/icons/hicolor/16x16/status/feed-presence.png
share/epiphany/icons/hicolor/22x22/status/ad-blocked.png
@@ -55,6 +66,7 @@ share/epiphany/icons/hicolor/32x32/status/feed-presence.png
share/epiphany/icons/hicolor/scalable/status/feed-presence.svg
share/gnome/help/epiphany-extensions/C/epiphany-extensions.xml
share/gnome/help/epiphany-extensions/C/figures/epi-ext-action-create.png
+share/gnome/help/epiphany-extensions/C/figures/epi-ext-actions-use.png
share/gnome/help/epiphany-extensions/C/figures/epi-ext-adblocker.png
share/gnome/help/epiphany-extensions/C/figures/epi-ext-gestures-back.png
share/gnome/help/epiphany-extensions/C/figures/epi-ext-gestures-close-2.png
@@ -76,6 +88,7 @@ share/gnome/help/epiphany-extensions/C/figures/epi-ext-tabgroups.png
share/gnome/help/epiphany-extensions/C/legal.xml
share/gnome/help/epiphany-extensions/de/epiphany-extensions.xml
share/gnome/help/epiphany-extensions/de/figures/epi-ext-action-create.png
+share/gnome/help/epiphany-extensions/de/figures/epi-ext-actions-use.png
share/gnome/help/epiphany-extensions/de/figures/epi-ext-adblocker.png
share/gnome/help/epiphany-extensions/de/figures/epi-ext-gestures-back.png
share/gnome/help/epiphany-extensions/de/figures/epi-ext-gestures-close-2.png
@@ -96,6 +109,7 @@ share/gnome/help/epiphany-extensions/de/figures/epi-ext-sidebar.png
share/gnome/help/epiphany-extensions/de/figures/epi-ext-tabgroups.png
share/gnome/help/epiphany-extensions/es/epiphany-extensions.xml
share/gnome/help/epiphany-extensions/es/figures/epi-ext-action-create.png
+share/gnome/help/epiphany-extensions/es/figures/epi-ext-actions-use.png
share/gnome/help/epiphany-extensions/es/figures/epi-ext-adblocker.png
share/gnome/help/epiphany-extensions/es/figures/epi-ext-gestures-back.png
share/gnome/help/epiphany-extensions/es/figures/epi-ext-gestures-close-2.png
@@ -116,6 +130,7 @@ share/gnome/help/epiphany-extensions/es/figures/epi-ext-sidebar.png
share/gnome/help/epiphany-extensions/es/figures/epi-ext-tabgroups.png
share/gnome/help/epiphany-extensions/fr/epiphany-extensions.xml
share/gnome/help/epiphany-extensions/fr/figures/epi-ext-action-create.png
+share/gnome/help/epiphany-extensions/fr/figures/epi-ext-actions-use.png
share/gnome/help/epiphany-extensions/fr/figures/epi-ext-adblocker.png
share/gnome/help/epiphany-extensions/fr/figures/epi-ext-gestures-back.png
share/gnome/help/epiphany-extensions/fr/figures/epi-ext-gestures-close-2.png
@@ -136,6 +151,7 @@ share/gnome/help/epiphany-extensions/fr/figures/epi-ext-sidebar.png
share/gnome/help/epiphany-extensions/fr/figures/epi-ext-tabgroups.png
share/gnome/help/epiphany-extensions/oc/epiphany-extensions.xml
share/gnome/help/epiphany-extensions/oc/figures/epi-ext-action-create.png
+share/gnome/help/epiphany-extensions/oc/figures/epi-ext-actions-use.png
share/gnome/help/epiphany-extensions/oc/figures/epi-ext-adblocker.png
share/gnome/help/epiphany-extensions/oc/figures/epi-ext-gestures-back.png
share/gnome/help/epiphany-extensions/oc/figures/epi-ext-gestures-close-2.png
@@ -156,6 +172,7 @@ share/gnome/help/epiphany-extensions/oc/figures/epi-ext-sidebar.png
share/gnome/help/epiphany-extensions/oc/figures/epi-ext-tabgroups.png
share/gnome/help/epiphany-extensions/sv/epiphany-extensions.xml
share/gnome/help/epiphany-extensions/sv/figures/epi-ext-action-create.png
+share/gnome/help/epiphany-extensions/sv/figures/epi-ext-actions-use.png
share/gnome/help/epiphany-extensions/sv/figures/epi-ext-adblocker.png
share/gnome/help/epiphany-extensions/sv/figures/epi-ext-gestures-back.png
share/gnome/help/epiphany-extensions/sv/figures/epi-ext-gestures-close-2.png
@@ -211,9 +228,11 @@ share/locale/pa/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/pl/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/pt/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/pt_BR/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
+share/locale/ro/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/ru/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/rw/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/sk/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
+share/locale/sl/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/sq/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/sr/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/sr@Latn/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
@@ -260,9 +279,7 @@ share/omf/epiphany-extensions/epiphany-extensions-sv.omf
@dirrmtry share/epiphany/icons/hicolor/16x16
@dirrmtry share/epiphany/icons/hicolor
@dirrmtry share/epiphany/icons
-@dirrmtry share/epiphany
-@dirrm %%DATADIR%%/xml
-@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%
@dirrmtry lib/epiphany/%%VERSION%%/extensions
@dirrmtry lib/epiphany/%%VERSION%%/plugins