aboutsummaryrefslogtreecommitdiffstats
path: root/www/epiphany/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-05-07 03:46:33 +0800
committerkwm <kwm@FreeBSD.org>2017-05-07 03:46:33 +0800
commitc80a70ba63445a0046c6559d5c7913cc506ac566 (patch)
tree3a08d363dd21cfcda51002ed9b5f1a7e626ee663 /www/epiphany/Makefile
parent6451b7b07fb0bdb180fb4f3087ff453993a5b783 (diff)
downloadfreebsd-ports-gnome-c80a70ba63445a0046c6559d5c7913cc506ac566.tar.gz
freebsd-ports-gnome-c80a70ba63445a0046c6559d5c7913cc506ac566.tar.zst
freebsd-ports-gnome-c80a70ba63445a0046c6559d5c7913cc506ac566.zip
Update epiphany to 3.22.7.
Obtained from: gnome devel repo
Diffstat (limited to 'www/epiphany/Makefile')
-rw-r--r--www/epiphany/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 73a1d228bcfc..9bf6a8c4844d 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= epiphany
-PORTVERSION= 3.16.3
-PORTREVISION= 3
+PORTVERSION= 3.22.7
CATEGORIES= www gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -11,17 +10,22 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Extremely lightweight and simple web browser for GNOME 3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= iso-codes>=0:misc/iso-codes \
itstool:textproc/itstool \
gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
+ libsoup-2.4.so:devel/libsoup \
libsoup-gnome-2.4.so:devel/libsoup-gnome \
libgcr-3.so:security/gcr \
libstartup-notification-1.so:x11/startup-notification \
libnss3.so:security/nss \
libavahi-gobject.so:net/avahi-app \
libnotify.so:devel/libnotify \
- libsecret-1.so:security/libsecret
+ libsecret-1.so:security/libsecret \
+ libp11-kit.so:security/p11-kit
RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
gnome-icon-theme-symbolic>=0:x11-themes/gnome-icon-theme-symbolic \
@@ -29,22 +33,21 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
PORTSCOUT= limitw:1,even
-USES= cpe desktop-file-utils gettext gmake libtool pathfix \
- pkgconfig python:3 sqlite tar:xz
+USES= cpe desktop-file-utils gettext gmake libtool localbase pathfix \
+ pkgconfig python:3.3+ sqlite tar:xz
CPE_VENDOR= gnome
-USE_GNOME= gnomedesktop3 intlhack libwnck3 libxml2 libxslt
-USE_XORG= ice x11 sm
+USE_GNOME= cairo gnomedesktop3 intlhack libwnck3 libxml2 libxslt
+USE_XORG= x11
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=\
--with-distributor-name="FreeBSD GNOME Project"
# --with-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.gnome.Epiphany.enums.xml \
+ org.gnome.epiphany.host.gschema.xml \
org.gnome.epiphany.gschema.xml
PLIST_SUB+= EPHY_VERSION=${PORTVERSION:R}