aboutsummaryrefslogtreecommitdiffstats
path: root/www/fhttpd/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-01-29 15:15:20 +0800
committersteve <steve@FreeBSD.org>2000-01-29 15:15:20 +0800
commit06dd5c1a282db9ce1349f126aa63e9c439e37756 (patch)
treed453d4e1300b4eac27f92e53b9e47541f770e603 /www/fhttpd/Makefile
parentf602ed0914080d541d0df55f65de00ddab3c00b2 (diff)
downloadfreebsd-ports-gnome-06dd5c1a282db9ce1349f126aa63e9c439e37756.tar.gz
freebsd-ports-gnome-06dd5c1a282db9ce1349f126aa63e9c439e37756.tar.zst
freebsd-ports-gnome-06dd5c1a282db9ce1349f126aa63e9c439e37756.zip
Adding fhttpd version 0.4.2.
A C++-based FTP/HTTP server that supports modules. PR: 15804 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'www/fhttpd/Makefile')
-rw-r--r--www/fhttpd/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/www/fhttpd/Makefile b/www/fhttpd/Makefile
new file mode 100644
index 000000000000..fe297573e67e
--- /dev/null
+++ b/www/fhttpd/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: fhttpd
+# Version required: 0.4.2
+# Date created: 21 Dec 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= fhttpd-0.4.2
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.fhttpd.org/
+
+MAINTAINER= andrews@technologist.com
+
+LOGFILE= share/fhttpd/fhttpd.log
+PLIST_SUB+= LOGFILE=${LOGFILE}
+
+post-extract:
+ @${CP} ${FILESDIR}/fhttpd.sh ${WRKSRC}
+
+pre-patch:
+ (cd ${WRKSRC} && ${TAR} xf http-root.tar)
+
+pre-install:
+ ${RM} -rf ${WRKSRC}/http-root/pub/dummy_directory
+ ${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/fhttpd.sh
+ ${PERL} -pi -e "s:%%LOGFILE%%:${PREFIX}/${LOGFILE}:g" ${WRKSRC}/fhttpd.sh
+ ${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/http-root/root-fhttpd.conf
+ ${PERL} -pi -e "s:%%LOGFILE%%:${PREFIX}/${LOGFILE}:g" ${WRKSRC}/http-root/root-fhttpd.conf
+
+do-install:
+ ${MKDIR} ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${WRKSRC}/fhttpd.sh ${PREFIX}/etc/rc.d
+.for PROG in fhttpd fhttpd-file fhttpd-log
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PROG} ${PREFIX}/sbin
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/http-root/root-fhttpd.conf ${PREFIX}/etc/fhttpd.conf
+ ${MKDIR} ${PREFIX}/share/fhttpd/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/http-root/bin/* ${PREFIX}/share/fhttpd/bin
+ ${MKDIR} ${PREFIX}/share/fhttpd/cgi-bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/http-root/cgi-bin/f* ${PREFIX}/share/fhttpd/cgi-bin
+ ${INSTALL_DATA} ${WRKSRC}/http-root/cgi-bin/.index.html ${PREFIX}/share/fhttpd/cgi-bin
+ ${MKDIR} ${PREFIX}/share/fhttpd/incoming
+.for DIR in icons private pub
+ ${MKDIR} ${PREFIX}/share/fhttpd/${DIR}
+ ${INSTALL_DATA} ${WRKSRC}/http-root/${DIR}/* ${PREFIX}/share/fhttpd/${DIR}/
+.endfor
+.for DIR in private pub
+ ${INSTALL_DATA} ${WRKSRC}/http-root/${DIR}/.[fhi]* ${PREFIX}/share/fhttpd/${DIR}/
+.endfor
+.for FILE in index.html noaccess.html
+ ${INSTALL_DATA} ${WRKSRC}/http-root/${FILE} ${PREFIX}/share/fhttpd/
+.endfor
+
+post-install:
+ ${TOUCH} ${PREFIX}/${LOGFILE}
+
+.include <bsd.port.mk>