aboutsummaryrefslogtreecommitdiffstats
path: root/www/fhttpd
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-15 16:38:17 +0800
committermiwi <miwi@FreeBSD.org>2006-12-15 16:38:17 +0800
commit894b8034224c0e42221e77775cbe14aa5258262e (patch)
tree773246383ee0c3c7e0616610195e1bdbd289ca83 /www/fhttpd
parent6a0c7f66a490b413b868af8ba21892c5b09e61db (diff)
downloadfreebsd-ports-gnome-894b8034224c0e42221e77775cbe14aa5258262e.tar.gz
freebsd-ports-gnome-894b8034224c0e42221e77775cbe14aa5258262e.tar.zst
freebsd-ports-gnome-894b8034224c0e42221e77775cbe14aa5258262e.zip
- Fix gcc 4.X build
PR: ports/106737 Submitted by: trasz
Diffstat (limited to 'www/fhttpd')
-rw-r--r--www/fhttpd/files/patch-ae17
-rw-r--r--www/fhttpd/files/patch-fhttpd.h13
-rw-r--r--www/fhttpd/pkg-plist82
3 files changed, 67 insertions, 45 deletions
diff --git a/www/fhttpd/files/patch-ae b/www/fhttpd/files/patch-ae
index 638f7ecc7971..d02ffd02651f 100644
--- a/www/fhttpd/files/patch-ae
+++ b/www/fhttpd/files/patch-ae
@@ -1,5 +1,5 @@
---- sockobj.cc.orig Sat May 15 07:13:54 1999
-+++ sockobj.cc Thu Jul 13 18:50:19 2000
+--- sockobj.cc.orig Sat May 15 13:13:54 1999
++++ sockobj.cc Fri Dec 15 00:37:45 2006
@@ -53,6 +53,7 @@
#include <stdarg.h>
#include <errno.h>
@@ -8,7 +8,16 @@
#include <sys/socket.h>
#include <sys/un.h>
#include <netinet/in.h>
-@@ -645,7 +646,7 @@
+@@ -93,6 +94,8 @@
+ extern int errno;
+ #endif
+
++void cleanupserverdriver(SIGARGS);
++
+ /****************************************
+ *** common daemon global variables
+ ****************************************/
+@@ -645,7 +648,7 @@
global_nconnections++;
if(xsocket->status==0){
hisaddresslength=128;
@@ -17,7 +26,7 @@
if(h<0) return;
hisaddress=(struct sockaddr*)malloc(hisaddresslength);
if(hisaddress) memcpy(hisaddress,s,hisaddresslength); else{
-@@ -1861,7 +1862,7 @@
+@@ -1861,7 +1864,7 @@
if(fdarray[sockets[i]->handleindexforwheel].revents&POLLIN){
fdarray[sockets[i]->handleindexforwheel].revents&=~POLLIN;
hisaddresslength=128;
diff --git a/www/fhttpd/files/patch-fhttpd.h b/www/fhttpd/files/patch-fhttpd.h
new file mode 100644
index 000000000000..b36c63d04936
--- /dev/null
+++ b/www/fhttpd/files/patch-fhttpd.h
@@ -0,0 +1,13 @@
+--- fhttpd.h.orig Fri Dec 15 00:34:52 2006
++++ fhttpd.h Fri Dec 15 00:35:10 2006
+@@ -249,8 +249,8 @@
+ void response(ServerConnection *client,char *fmt,...);
+ void hugeresponse(ServerConnection *client,char *buffer,unsigned long size);
+ void setexitafterresponse(ServerConnection *client,int closeonexit);
+-int ControlFTPServer::getexitafterresponse(ServerConnection *client);
+-void ControlFTPServer::emptyresponse(ServerConnection *client);
++int getexitafterresponse(ServerConnection *client);
++void emptyresponse(ServerConnection *client);
+ void suspendpollforresponse(ServerConnection *client,int startpollonexit);
+
+ void answer_to_list(char *buffer,int i,int *syncexpected,
diff --git a/www/fhttpd/pkg-plist b/www/fhttpd/pkg-plist
index fa15a524bba8..93dc8ce9c30d 100644
--- a/www/fhttpd/pkg-plist
+++ b/www/fhttpd/pkg-plist
@@ -4,44 +4,44 @@ etc/rc.d/fhttpd.sh
sbin/fhttpd
sbin/fhttpd-file
sbin/fhttpd-log
-share/fhttpd/bin/finger-nohtml
-share/fhttpd/cgi-bin/.index.html
-share/fhttpd/cgi-bin/finger
-share/fhttpd/cgi-bin/fortune
-share/fhttpd/icons/at_work.gif
-share/fhttpd/icons/audio.gif
-share/fhttpd/icons/audio.xbm
-share/fhttpd/icons/binary.gif
-share/fhttpd/icons/binary.xbm
-share/fhttpd/icons/c_text.gif
-share/fhttpd/icons/c_text.xbm
-share/fhttpd/icons/cdromicon.gif
-share/fhttpd/icons/exec.gif
-share/fhttpd/icons/folder.gif
-share/fhttpd/icons/folder.xbm
-share/fhttpd/icons/ftp.gif
-share/fhttpd/icons/html.gif
-share/fhttpd/icons/html.xbm
-share/fhttpd/icons/image.gif
-share/fhttpd/icons/image.xbm
-share/fhttpd/icons/movie.gif
-share/fhttpd/icons/text.gif
-share/fhttpd/icons/text.xbm
-share/fhttpd/index.html
-share/fhttpd/noaccess.html
-share/fhttpd/private/.footer.html
-share/fhttpd/private/.header.html
-share/fhttpd/private/.index.html
-share/fhttpd/private/dummy_file
-share/fhttpd/private/dummy_file.html
-share/fhttpd/pub/.footer.html
-share/fhttpd/pub/.header.html
-share/fhttpd/pub/.index.html
-share/fhttpd/pub/dummy_file.html
-@dirrm share/fhttpd/bin
-@dirrm share/fhttpd/cgi-bin
-@dirrm share/fhttpd/icons
-@dirrm share/fhttpd/incoming
-@dirrm share/fhttpd/private
-@dirrm share/fhttpd/pub
-@dirrm share/fhttpd
+%%DATADIR%%/bin/finger-nohtml
+%%DATADIR%%/cgi-bin/.index.html
+%%DATADIR%%/cgi-bin/finger
+%%DATADIR%%/cgi-bin/fortune
+%%DATADIR%%/icons/at_work.gif
+%%DATADIR%%/icons/audio.gif
+%%DATADIR%%/icons/audio.xbm
+%%DATADIR%%/icons/binary.gif
+%%DATADIR%%/icons/binary.xbm
+%%DATADIR%%/icons/c_text.gif
+%%DATADIR%%/icons/c_text.xbm
+%%DATADIR%%/icons/cdromicon.gif
+%%DATADIR%%/icons/exec.gif
+%%DATADIR%%/icons/folder.gif
+%%DATADIR%%/icons/folder.xbm
+%%DATADIR%%/icons/ftp.gif
+%%DATADIR%%/icons/html.gif
+%%DATADIR%%/icons/html.xbm
+%%DATADIR%%/icons/image.gif
+%%DATADIR%%/icons/image.xbm
+%%DATADIR%%/icons/movie.gif
+%%DATADIR%%/icons/text.gif
+%%DATADIR%%/icons/text.xbm
+%%DATADIR%%/index.html
+%%DATADIR%%/noaccess.html
+%%DATADIR%%/private/.footer.html
+%%DATADIR%%/private/.header.html
+%%DATADIR%%/private/.index.html
+%%DATADIR%%/private/dummy_file
+%%DATADIR%%/private/dummy_file.html
+%%DATADIR%%/pub/.footer.html
+%%DATADIR%%/pub/.header.html
+%%DATADIR%%/pub/.index.html
+%%DATADIR%%/pub/dummy_file.html
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%/cgi-bin
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/incoming
+@dirrm %%DATADIR%%/private
+@dirrm %%DATADIR%%/pub
+@dirrm %%DATADIR%%