aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr/files
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-10-29 07:47:31 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:50:17 +0800
commit588f2cd66f8aebe57db1b23221e2b4bee7356be5 (patch)
treed2cbd725208e86171f8ee9c27471f129be70812b /www/firefox-esr/files
parent1b9abb431eb9a77d9f2f3d235adb0cfa9be5daeb (diff)
downloadfreebsd-ports-gnome-588f2cd66f8aebe57db1b23221e2b4bee7356be5.tar.gz
freebsd-ports-gnome-588f2cd66f8aebe57db1b23221e2b4bee7356be5.tar.zst
freebsd-ports-gnome-588f2cd66f8aebe57db1b23221e2b4bee7356be5.zip
gecko: speed up VP9 decoding on i386
Disable bundled FFmpeg decoders for VP* and FLAC on i386 as those don't support SIMD optimizations due to build issues upstream. More recent versions of those are already provided by multimedia/ffmpeg, anyway. MFH: 2017Q4
Diffstat (limited to 'www/firefox-esr/files')
-rw-r--r--www/firefox-esr/files/patch-bug141255873
1 files changed, 73 insertions, 0 deletions
diff --git a/www/firefox-esr/files/patch-bug1412558 b/www/firefox-esr/files/patch-bug1412558
new file mode 100644
index 000000000000..ffa49490caf6
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1412558
@@ -0,0 +1,73 @@
+diff --git dom/media/flac/FlacDecoder.cpp dom/media/flac/FlacDecoder.cpp
+index 53fc3c9937f7..b23771ab80fa 100644
+--- dom/media/flac/FlacDecoder.cpp
++++ dom/media/flac/FlacDecoder.cpp
+@@ -36,7 +36,7 @@ FlacDecoder::CreateStateMachine()
+ /* static */ bool
+ FlacDecoder::IsEnabled()
+ {
+-#ifdef MOZ_FFVPX
++#if defined(MOZ_FFMPEG) || defined(MOZ_FFVPX)
+ return MediaPrefs::FlacEnabled();
+ #else
+ // Until bug 1295886 is fixed.
+diff --git media/ffvpx/README_MOZILLA media/ffvpx/README_MOZILLA
+index 5d3a6037efe0..43144b726a92 100644
+--- media/ffvpx/README_MOZILLA
++++ media/ffvpx/README_MOZILLA
+@@ -17,14 +17,6 @@ configuration files were generated as follow using the configure script:
+ config*:
+ replace: /HAVE_(MALLOC_H|ARC4RANDOM|LOCALTIME_R|MEMALIGN|POSIX_MEMALIGN)/d
+
+-config_darwin32.h:
+-add to configure command: --disable-asm --disable-yasm --cc='clang -m32'
+-
+-config_unix32.h:
+-add to configure command: --disable-asm --disable-yasm --cc='clang -m32'
+-replace: s/HAVE_SYSCTL 1/HAVE_SYSCTL 0/ and s/HAVE_MEMALIGN 1/HAVE_MEMALIGN 0/ and s/HAVE_POSIX_MEMALIGN 1/HAVE_POSIX_MEMALIGN 0/
+-
+-
+ config_unix64.h/config_unix64.asm:
+ replace: s/HAVE_SYSCTL 1/HAVE_SYSCTL 0
+
+diff --git media/ffvpx/config.h media/ffvpx/config.h
+index dab01e05cd65..26ebe529bd98 100644
+--- media/ffvpx/config.h
++++ media/ffvpx/config.h
+@@ -27,17 +27,9 @@
+ #define HAVE_LIBC_MSVCRT 0
+ #endif
+ #elif defined(XP_DARWIN)
+-#if defined(HAVE_64BIT_BUILD)
+ #include "config_darwin64.h"
+-#else
+-#include "config_darwin32.h"
+-#endif
+ #elif defined(XP_UNIX)
+-#if defined(HAVE_64BIT_BUILD)
+ #include "config_unix64.h"
+-#else
+-#include "config_unix32.h"
+-#endif
+ #endif
+ #include "config_common.h"
+ #endif // MOZ_FFVPX_CONFIG_H
+diff --git old-configure.in old-configure.in
+index b8ce71278548..410be683c2f6 100644
+--- old-configure.in
++++ old-configure.in
+@@ -3279,11 +3279,11 @@ dnl = FFmpeg's ffvpx configuration
+ dnl ========================================================
+
+ MOZ_FFVPX=
+-case "$CPU_ARCH" in
+- x86)
++case "$OS_ARCH:$CPU_ARCH" in
++ WINNT:x86)
+ MOZ_FFVPX=1
+ ;;
+- x86_64)
++ *:x86_64)
+ MOZ_FFVPX=1
+ ;;
+ esac