aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-12-15 06:49:59 +0800
committeralane <alane@FreeBSD.org>2002-12-15 06:49:59 +0800
commitc4d5940314c9cc34ec927e7a46557404f7b2f4ed (patch)
tree93cbab5e24b7c323f3c62258b856c704e2236ab4 /www/firefox-esr
parent47e8e9b2378aa0577111ed1d0ffb8d880e61b946 (diff)
downloadfreebsd-ports-gnome-c4d5940314c9cc34ec927e7a46557404f7b2f4ed.tar.gz
freebsd-ports-gnome-c4d5940314c9cc34ec927e7a46557404f7b2f4ed.tar.zst
freebsd-ports-gnome-c4d5940314c9cc34ec927e7a46557404f7b2f4ed.zip
The problem wasn't the patch, it was third party font ports. The patch has
been restored, extra knobs have added, and extensive diagnostics have been added. PLEASE upgrade to this version. Approved by: kris (part of phoenix upgrade)
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile33
-rw-r--r--www/firefox-esr/files/mozconfig.in18
-rw-r--r--www/firefox-esr/files/patch-nsprpub-pr-src-pthreads-ptio.c22
3 files changed, 67 insertions, 6 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 87ad5278d832..b6a6ce1dcb53 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -9,7 +9,7 @@
PORTNAME= phoenix
PORTVERSION= 0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www # pita
MASTER_SITES= ${MASTER_SITE_LOCAL} ${BSD_WEBDIR}
MASTER_SITE_SUBDIR= alane
@@ -21,7 +21,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2 \
IDL.2:${PORTSDIR}/devel/ORBit \
- Xft2.2:${PORTSDIR}/x11-fonts/Xft \
iconv.3:${PORTSDIR}/converters/libiconv
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
@@ -60,6 +59,7 @@ SORT?=/usr/bin/sort
PLIST=${WRKDIR}/plist
.if defined(WITH_DEBUG)
+WITH_LOGGING= yes
WITHOUT_OPTIMIZE= yes
CONFIGURE_ENV+= WITH_DEBUG=yes
.endif # defined(WITH_DEBUG)
@@ -68,6 +68,35 @@ CONFIGURE_ENV+= WITH_DEBUG=yes
CFLAGS+= -O2
.endif # defined(WITH_OPTIMIZE)
+.if defined(WITH_LOGGING)
+CONFIGURE_ENV+= WITH_LOGGING=yes
+.endif # defined(WITH_LOGGING)
+
+.if defined(WITHOUT_XFT)
+CONFIGURE_ENV+= WITHOUT_XFT=yes
+.else
+LIB_DEPENDS+= Xft2.2:${PORTSDIR}/x11-fonts/Xft
+.endif # !defined(WITHOUT_XFT)
+
+# check for known bad fonts
+.if exists(${X11BASE}/lib/X11/fonts/lfpfonts-var/fonts.dir)
+BAD_FONTS=yes
+.endif # exists(${X11BASE}/lib/X11/fonts/lfpfonts-var/fonts.dir)
+.if exists(${X11BASE}/lib/X11/fonts/lfpfonts-fix/fonts.dir)
+BAD_FONTS=yes
+.endif # exists(${X11BASE}/lib/X11/fonts/lfpfonts-var/fonts.dir)
+
+.if defined(BAD_FONTS) && !defined(WITHOUT_XFT)
+.undef NO_IGNORE
+BROKEN= "You have X fonts installed (lfpfonts*) that cause breakage unless"
+BROKEN+="WITHOUT_XFT is set, which turns off AntiAliasing. Blease either"
+BROKEN+="uninstall the fonts or restart the make with 'make -DWITHOUT_XFT'."
+BROKEN+="There may be other third party font packages that also cause this"
+BROKEN+="breakage; they will be tested for as they are identified. If you"
+BROKEN+="find a font port that verifiably causes this breakage, please"
+BROKEN+="let us know by mailing ${MAINTAINER}. Thank you."
+BROKEN+="NOTE: The Microsoft webfonts port is known to be safe."
+.endif # defined(BAD_FONTS) && !defined(WITHOUT_XFT)
CPPFLAGS+= -I${X11BASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/www/firefox-esr/files/mozconfig.in b/www/firefox-esr/files/mozconfig.in
index 2bea08b6719a..50703b5df336 100644
--- a/www/firefox-esr/files/mozconfig.in
+++ b/www/firefox-esr/files/mozconfig.in
@@ -33,13 +33,12 @@ ac_add_options --with-system-zlib
ac_add_options --with-system-png=@LOCALBASE@
ac_add_options --with-system-mng=@LOCALBASE@
######################################################################
-# enable features
+# set compile/link features
ac_add_options --with-pthreads
-ac_add_options --enable-xft
ac_add_options --enable-reorder
ac_add_options --enable-strip
######################################################################
-# disable unneeded to speed up and/or save space
+# disable unneeded/unavailable
ac_add_options --disable-auto-deps
ac_add_options --disable-bidi
ac_add_options --disable-dtd-debug
@@ -47,10 +46,21 @@ ac_add_options --disable-jsd
ac_add_options --disable-ldap
ac_add_options --disable-pedantic
ac_add_options --disable-xinerama
+######################################################################
+# conditional from port Makefile
if test -n "$WITH_DEBUG"; then
ac_add_options --enable-debug
+else
+ ac_add_options --disable-debug
+fi # test -n "$WITH_DEBUG"
+if test -n "$WITH_LOGGING"; then
ac_add_options --enable-logging
else
ac_add_options --disable-logging
-fi # test -n "$WITH_DEBUG"
+fi # test -n "$WITH_LOGGING"
+if test -z "$WITHOUT_XFT"; then
+ ac_add_options --enable-xft
+else
+ ac_add_options --disable-xft
+fi # test -z "$WITHOUT_XFT"
######################################################################
diff --git a/www/firefox-esr/files/patch-nsprpub-pr-src-pthreads-ptio.c b/www/firefox-esr/files/patch-nsprpub-pr-src-pthreads-ptio.c
new file mode 100644
index 000000000000..4a965d4c7440
--- /dev/null
+++ b/www/firefox-esr/files/patch-nsprpub-pr-src-pthreads-ptio.c
@@ -0,0 +1,22 @@
+Index: nsprpub/pr/src/pthreads/ptio.c
+diff -u nsprpub/pr/src/pthreads/ptio.c.orig nsprpub/pr/src/pthreads/ptio.c
+--- nsprpub/pr/src/pthreads/ptio.c.orig Fri Apr 12 03:14:39 2002
++++ nsprpub/pr/src/pthreads/ptio.c Tue Jul 30 18:52:11 2002
+@@ -3414,6 +3414,17 @@
+ if (osfd == -1) pt_MapError(_PR_MD_MAP_SOCKET_ERROR, errno);
+ else
+ {
++#if (defined(_PR_INET6_PROBE) || defined(_PR_INET6)) && \
++ defined(__FreeBSD__) && defined(IPV6_V6ONLY)
++ if (domain == PR_AF_INET6) {
++ int opt = 0;
++ if (setsockopt(osfd, IPPROTO_IPV6, IPV6_V6ONLY,
++ &opt, sizeof(opt))) {
++ close(osfd);
++ return NULL;
++ }
++ }
++#endif
+ fd = pt_SetMethods(osfd, ftype, PR_FALSE, PR_FALSE);
+ if (fd == NULL) close(osfd);
+ }