aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-12-15 14:03:30 +0800
committermarcus <marcus@FreeBSD.org>2004-12-15 14:03:30 +0800
commite34c351554523768d6cad0af717114b3d1984a2f (patch)
tree3e91beba00e5abf1e32e0b0adc5f7d6c1ade4f36 /www/firefox-esr
parenteb1a6deca1e5c40cf1e1e0b9659c35aeeb1e871a (diff)
downloadfreebsd-ports-gnome-e34c351554523768d6cad0af717114b3d1984a2f.tar.gz
freebsd-ports-gnome-e34c351554523768d6cad0af717114b3d1984a2f.tar.zst
freebsd-ports-gnome-e34c351554523768d6cad0af717114b3d1984a2f.zip
* Fix build with upcoming X.Org 6.8.1 [1]
* Temporarily disable CUPS support to fix a crash do to a symbol conflict between OpenSSL and NSS [2] PR: 75045 [2] Submitted by: lesi [1]
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile4
-rw-r--r--www/firefox-esr/files/mozconfig.in2
-rw-r--r--www/firefox-esr/files/patch-config::mkdepend::Makefile.in10
3 files changed, 15 insertions, 1 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index e5c044e9e151..aeecbba11251 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -144,6 +144,8 @@ post-patch:
${WRKSRC}/js/src/Makefile.in
@${REINPLACE_CMD} -e 's|libesd\.so\.\d+|${ESD_LIB}|g' \
${WRKSRC}/widget/src/gtk2/nsSound.cpp
+ @${REINPLACE_CMD} -E -e 's|libcups\.so\.[0-9]+|libcups.no|g' \
+ ${WRKSRC}/gfx/src/gtk/nsDeviceContextSpecG.cpp
.for ii in modules/libpref/src/init extensions/sroaming/resources/content/prefs \
embedding/minimo
@${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/ ; \
diff --git a/www/firefox-esr/files/mozconfig.in b/www/firefox-esr/files/mozconfig.in
index 26bd8e79d771..a2c8dccba3ac 100644
--- a/www/firefox-esr/files/mozconfig.in
+++ b/www/firefox-esr/files/mozconfig.in
@@ -22,6 +22,8 @@ export PERL="@PERL@"
mk_add_options PERL=$PERL
# Configure options for installation
ac_add_options --prefix=@FAKEDIR@
+ac_add_options --x-includes=@X11BASE@/include
+ac_add_options --x-libraries=@X11BASE@/lib
######################################################################
# Use ports for these libraries
ac_add_options --with-system-jpeg=@LOCALBASE@
diff --git a/www/firefox-esr/files/patch-config::mkdepend::Makefile.in b/www/firefox-esr/files/patch-config::mkdepend::Makefile.in
new file mode 100644
index 000000000000..bace012a282e
--- /dev/null
+++ b/www/firefox-esr/files/patch-config::mkdepend::Makefile.in
@@ -0,0 +1,10 @@
+--- config/mkdepend/Makefile.in.orig Sun Dec 12 07:36:57 2004
++++ config/mkdepend/Makefile.in Sun Dec 12 07:37:55 2004
+@@ -57,6 +57,7 @@
+ include $(topsrcdir)/config/rules.mk
+
+ HOST_CFLAGS += -DINCLUDEDIR=\"/usr/include\" -DOBJSUFFIX=\".$(OBJ_SUFFIX)\"
++HOST_CFLAGS += $(XCFLAGS)
+
+ ifdef GNU_CC
+ _GCCDIR = $(shell $(CC) -print-file-name=include)