aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-03-04 03:38:13 +0800
committerjbeich <jbeich@FreeBSD.org>2017-03-04 03:38:13 +0800
commit0f03a2eb907ae62aaa94d52053c334290a5fcd84 (patch)
tree7d3284e05228817e5a098f0866e33d8843538a73 /www/firefox-esr
parent65465b5dfd10d04bfe8bcedc24b16f547b617c60 (diff)
downloadfreebsd-ports-gnome-0f03a2eb907ae62aaa94d52053c334290a5fcd84.tar.gz
freebsd-ports-gnome-0f03a2eb907ae62aaa94d52053c334290a5fcd84.tar.zst
freebsd-ports-gnome-0f03a2eb907ae62aaa94d52053c334290a5fcd84.zip
gecko: attempt to drop RPATH for libxul.so dependencies
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug133679121
2 files changed, 22 insertions, 1 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 1b7bcd165bdf..46158e6fb46a 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 45.8.0
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1336791 b/www/firefox-esr/files/patch-bug1336791
new file mode 100644
index 000000000000..e9ed891a4c56
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1336791
@@ -0,0 +1,21 @@
+# Allow readelf to print types without parentheses
+
+--- toolkit/library/dependentlibs.py
++++ toolkit/library/dependentlibs.py
+@@ -57,11 +57,15 @@ def dependentlibs_readelf(lib):
+ for line in proc.stdout:
+ # Each line has the following format:
+ # tag (TYPE) value
++ # or with BSD readelf:
++ # tag TYPE value
+ # Looking for NEEDED type entries
+ tmp = line.split(' ', 3)
+- if len(tmp) > 3 and tmp[2] == '(NEEDED)':
++ if len(tmp) > 3 and 'NEEDED' in tmp[2]:
+ # NEEDED lines look like:
+ # 0x00000001 (NEEDED) Shared library: [libname]
++ # or with BSD readelf:
++ # 0x00000001 NEEDED Shared library: [libname]
+ match = re.search('\[(.*)\]', tmp[3])
+ if match:
+ deps.append(match.group(1))