aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-09-08 06:10:01 +0800
committerflo <flo@FreeBSD.org>2012-09-08 06:10:01 +0800
commitf8ae57259d2b6995d3f55494b27d00983b0eab62 (patch)
tree260671c3ea7a2a410e3f9cc7f050e3a71604a633 /www/firefox-esr
parentf282aa59ea4a4c778851cc8c8e9910f59bc43330 (diff)
downloadfreebsd-ports-gnome-f8ae57259d2b6995d3f55494b27d00983b0eab62.tar.gz
freebsd-ports-gnome-f8ae57259d2b6995d3f55494b27d00983b0eab62.tar.zst
freebsd-ports-gnome-f8ae57259d2b6995d3f55494b27d00983b0eab62.zip
- Update firefox to 15.0.1
- Sync changes from gecko repository@r995 general - don't specify prefix for libevent when using pkg-config - ia64 and sparc64 use 8k pagesize by default - add visibility hack for clang 3.2 with libc++ - fix build using clang 3.2 (on FreeBSD 10-CURRENT) - rename a few more patches to ease tracking of bugzilla bugs www/seamonkey - unbreak unsetting LDAP and MAILNEWS options after bug 707305 - use compile time debugging WITH_DEBUG security/nss - unbreak install WITH_DEBUG - unbreak powerpc64 devel/nspr - use absolute paths when specifiying srcdir to make gdb(1) happy In collaboration with: andreast, zeising, Jan Beich <jbeich@tormail.org>
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/files/patch-bug351181 (renamed from www/firefox-esr/files/patch-js_src_jsnum.cpp)0
-rw-r--r--www/firefox-esr/files/patch-bug543241 (renamed from www/firefox-esr/files/patch-xpcom__threads__nsThreadManager.cpp)0
-rw-r--r--www/firefox-esr/files/patch-bug65355129
-rw-r--r--www/firefox-esr/files/patch-bug72896850
-rw-r--r--www/firefox-esr/files/patch-bug7530466
-rw-r--r--www/firefox-esr/files/patch-bug78803959
-rw-r--r--www/firefox-esr/files/patch-clang32-libc++-visibility-hack38
-rw-r--r--www/firefox-esr/files/patch-configure.in52
-rw-r--r--www/firefox-esr/files/patch-ipc-chromium-Makefile.in2
-rw-r--r--www/firefox-esr/files/patch-js-src-configure.in16
10 files changed, 182 insertions, 70 deletions
diff --git a/www/firefox-esr/files/patch-js_src_jsnum.cpp b/www/firefox-esr/files/patch-bug351181
index ea2515a74d94..ea2515a74d94 100644
--- a/www/firefox-esr/files/patch-js_src_jsnum.cpp
+++ b/www/firefox-esr/files/patch-bug351181
diff --git a/www/firefox-esr/files/patch-xpcom__threads__nsThreadManager.cpp b/www/firefox-esr/files/patch-bug543241
index 73db2c3a785e..73db2c3a785e 100644
--- a/www/firefox-esr/files/patch-xpcom__threads__nsThreadManager.cpp
+++ b/www/firefox-esr/files/patch-bug543241
diff --git a/www/firefox-esr/files/patch-bug653551 b/www/firefox-esr/files/patch-bug653551
new file mode 100644
index 000000000000..f9316f0f725b
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug653551
@@ -0,0 +1,29 @@
+commit 47ea30f
+Author: Landry Breuil <landry@openbsd.org>
+Date: Thu Feb 2 15:31:56 2012 +0900
+
+ Bug 653551 - Jaegermonkey Sparc back-end broken on sparc64. r=leon.sha
+---
+ js/src/configure.in | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git js/src/configure.in js/src/configure.in
+index 84390cf..d663c46 100644
+--- js/src/configure.in
++++ js/src/configure.in
+@@ -2806,13 +2806,15 @@ arm*-*)
+ AC_DEFINE(JS_NUNBOX32)
+ ;;
+ sparc*-*)
++ if test ! "$HAVE_64BIT_OS" ; then
+ NANOJIT_ARCH=Sparc
+ ENABLE_METHODJIT=1
+ ENABLE_MONOIC=1
+ ENABLE_POLYIC=1
+ ENABLE_METHODJIT_TYPED_ARRAY=1
+ AC_DEFINE(JS_CPU_SPARC)
+ AC_DEFINE(JS_NUNBOX32)
++ fi
+ ;;
+ mips*-*)
+ ENABLE_METHODJIT=1
diff --git a/www/firefox-esr/files/patch-bug728968 b/www/firefox-esr/files/patch-bug728968
new file mode 100644
index 000000000000..01638e8fd119
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug728968
@@ -0,0 +1,50 @@
+commit 4075972
+Author: Mike Hommey <mh+mozilla@glandium.org>
+Date: Thu Feb 23 11:00:46 2012 +0100
+
+ Bug 728968 - Detect clock_gettime when it's not in -lrt. r=khuey
+---
+ configure.in | 29 ++++++++++++++++-------------
+ 1 file changed, 16 insertions(+), 13 deletions(-)
+
+diff --git configure.in configure.in
+index 3ba7e2f..3d0614c 100644
+--- configure.in
++++ configure.in
+@@ -3728,20 +3728,23 @@ AC_CHECK_FUNCS(random strerror lchown fchmod snprintf statvfs memmove rint stat6
+ AC_CHECK_FUNCS(flockfile getpagesize)
+ AC_CHECK_FUNCS(localtime_r strtok_r)
+
+-dnl check for clock_gettime(), the CLOCK_MONOTONIC clock, and -lrt
+-_SAVE_LDFLAGS=$LDFLAGS
+-LDFLAGS="$LDFLAGS -lrt"
+-AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC) and -lrt,
+- ac_cv_have_clock_monotonic,
+- [AC_TRY_LINK([#include <time.h>],
+- [ struct timespec ts;
+- clock_gettime(CLOCK_MONOTONIC, &ts); ],
+- ac_cv_have_clock_monotonic=yes,
+- ac_cv_have_clock_monotonic=no)])
+-LDFLAGS=$_SAVE_LDFLAGS
+-if test "$ac_cv_have_clock_monotonic" = "yes"; then
++dnl check for clock_gettime(), the CLOCK_MONOTONIC clock
++AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC),
++ ac_cv_clock_monotonic,
++ [for libs in "" -lrt; do
++ _SAVE_LDFLAGS="$LDFLAGS"
++ LDFLAGS="$LDFLAGS $libs"
++ AC_TRY_LINK([#include <time.h>],
++ [ struct timespec ts;
++ clock_gettime(CLOCK_MONOTONIC, &ts); ],
++ ac_cv_clock_monotonic=$libs
++ break,
++ ac_cv_clock_monotonic=no)
++ LDFLAGS="$_SAVE_LDFLAGS"
++ done])
++if test "$ac_cv_clock_monotonic" != "no"; then
+ HAVE_CLOCK_MONOTONIC=1
+- REALTIME_LIBS=-lrt
++ REALTIME_LIBS=$ac_cv_clock_monotonic
+ AC_DEFINE(HAVE_CLOCK_MONOTONIC)
+ AC_SUBST(HAVE_CLOCK_MONOTONIC)
+ AC_SUBST(REALTIME_LIBS)
diff --git a/www/firefox-esr/files/patch-bug753046 b/www/firefox-esr/files/patch-bug753046
index 2971fe61bf64..48c16e5db2e1 100644
--- a/www/firefox-esr/files/patch-bug753046
+++ b/www/firefox-esr/files/patch-bug753046
@@ -264,7 +264,7 @@ new file mode 100644
index 0000000..3fc1a87
--- /dev/null
+++ ipc/chromium/src/base/dir_reader_bsd.h
-@@ -0,0 +1,108 @@
+@@ -0,0 +1,112 @@
+// Copyright (c) 2010 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
@@ -316,7 +316,11 @@ index 0000000..3fc1a87
+ bool Next() {
+ if (size_) {
+ struct dirent* dirent = reinterpret_cast<struct dirent*>(&buf_[offset_]);
++#ifdef OS_DRAGONFLY
++ offset_ += _DIRENT_DIRSIZ(dirent);
++#else
+ offset_ += dirent->d_reclen;
++#endif
+ }
+
+ if (offset_ != size_)
diff --git a/www/firefox-esr/files/patch-bug788039 b/www/firefox-esr/files/patch-bug788039
new file mode 100644
index 000000000000..678f0d493eae
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug788039
@@ -0,0 +1,59 @@
+# Bug 788039 - With no prefix search libevent via pkg-config.
+
+--- config/autoconf.mk.in~
++++ config/autoconf.mk.in
+@@ -227,7 +227,7 @@ MOZ_HUNSPELL_CFLAGS = @MOZ_HUNSPELL_CFLA
+
+ MOZ_NATIVE_LIBEVENT = @MOZ_NATIVE_LIBEVENT@
+ MOZ_LIBEVENT_LIBS = @MOZ_LIBEVENT_LIBS@
+-MOZ_LIBEVENT_INCLUDES = @MOZ_LIBEVENT_INCLUDES@
++MOZ_LIBEVENT_CFLAGS = @MOZ_LIBEVENT_CFLAGS@
+
+ MOZ_NATIVE_LIBVPX = @MOZ_NATIVE_LIBVPX@
+ MOZ_LIBVPX_LIBS = @MOZ_LIBVPX_LIBS@
+--- configure.in~
++++ configure.in
+@@ -3854,7 +3854,7 @@ fi
+ dnl system libevent Support
+ dnl ========================================================
+ MOZ_ARG_WITH_STRING(system-libevent,
+-[ --with-system-libevent=[PFX]
++[ --with-system-libevent[=PFX]
+ Use system libevent [installed at prefix PFX]],
+ LIBEVENT_DIR=$withval)
+
+@@ -3863,10 +3863,11 @@ _SAVE_LDFLAGS=$LDFLAGS
+ _SAVE_LIBS=$LIBS
+ if test -z "$LIBEVENT_DIR" -o "$LIBEVENT_DIR" = no; then
+ MOZ_NATIVE_LIBEVENT=
++elif test "$LIBEVENT_DIR" = yes; then
++ PKG_CHECK_MODULES(MOZ_LIBEVENT, libevent,
++ MOZ_NATIVE_LIBEVENT=1,
++ AC_MSG_ERROR([--with-system-libevent requested but libevent package not found]))
+ else
+- if test "${LIBEVENT_DIR}" = "yes"; then
+- LIBEVENT_DIR=/usr
+- fi
+ CFLAGS="-I${LIBEVENT_DIR}/include $CFLAGS"
+ LDFLAGS="-L${LIBEVENT_DIR}/lib $LDFLAGS"
+ MOZ_CHECK_HEADER(event.h,
+@@ -3876,16 +3877,16 @@ else
+ AC_MSG_ERROR([--with-system-libevent requested but event.h not found]))
+ AC_CHECK_LIB(event, event_init,
+ [MOZ_NATIVE_LIBEVENT=1
+- MOZ_LIBEVENT_INCLUDES="${LIBEVENT_DIR}/include"
++ MOZ_LIBEVENT_CFLAGS="-I${LIBEVENT_DIR}/include"
+ MOZ_LIBEVENT_LIBS="-L${LIBEVENT_DIR}/lib -levent"],
+- [MOZ_NATIVE_LIBEVENT= MOZ_LIBEVENT_INCLUDES= MOZ_LIBEVENT_LIBS=])
++ [MOZ_NATIVE_LIBEVENT= MOZ_LIBEVENT_CFLAGS= MOZ_LIBEVENT_LIBS=])
+ fi
+ CFLAGS=$_SAVE_CFLAGS
+ LDFLAGS=$_SAVE_LDFLAGS
+ LIBS=$_SAVE_LIBS
+
+ AC_SUBST(MOZ_NATIVE_LIBEVENT)
+-AC_SUBST(MOZ_LIBEVENT_INCLUDES)
++AC_SUBST(MOZ_LIBEVENT_CFLAGS)
+ AC_SUBST(MOZ_LIBEVENT_LIBS)
+
+ dnl ========================================================
diff --git a/www/firefox-esr/files/patch-clang32-libc++-visibility-hack b/www/firefox-esr/files/patch-clang32-libc++-visibility-hack
new file mode 100644
index 000000000000..ccada32cbee3
--- /dev/null
+++ b/www/firefox-esr/files/patch-clang32-libc++-visibility-hack
@@ -0,0 +1,38 @@
+--- configure.in~
++++ configure.in
+@@ -2855,6 +2855,7 @@ EOF
+ #pragma GCC visibility push(hidden)
+ #pragma GCC visibility push(default)
+ #include <string.h>
++#include <iterator>
+ #pragma GCC visibility pop
+
+ __attribute__ ((visibility ("default"))) void Func() {
+@@ -2863,7 +2864,7 @@ __attribute__ ((visibility ("default"))) void Func() {
+ }
+ EOF
+ ac_cv_have_visibility_builtin_bug=no
+- if ! ${CC-cc} ${CFLAGS} ${DSO_PIC_CFLAGS} ${DSO_LDOPTS} -O2 -S -o conftest.S conftest.c > /dev/null 2>&1 ; then
++ if ! ${CXX-c++} ${CXXFLAGS} ${DSO_PIC_CFLAGS} ${DSO_LDOPTS} -O2 -S -o conftest.S conftest.c > /dev/null 2>&1 ; then
+ ac_cv_have_visibility_builtin_bug=yes
+ else
+ if test `grep -c "@PLT" conftest.S` = 0; then
+--- js/src/configure.in~
++++ js/src/configure.in
+@@ -2855,6 +2855,7 @@ EOF
+ #pragma GCC visibility push(hidden)
+ #pragma GCC visibility push(default)
+ #include <string.h>
++#include <iterator>
+ #pragma GCC visibility pop
+
+ __attribute__ ((visibility ("default"))) void Func() {
+@@ -2863,7 +2864,7 @@ __attribute__ ((visibility ("default"))) void Func() {
+ }
+ EOF
+ ac_cv_have_visibility_builtin_bug=no
+- if ! ${CC-cc} ${CFLAGS} ${DSO_PIC_CFLAGS} ${DSO_LDOPTS} -O2 -S -o conftest.S conftest.c > /dev/null 2>&1 ; then
++ if ! ${CXX-c++} ${CXXFLAGS} ${DSO_PIC_CFLAGS} ${DSO_LDOPTS} -O2 -S -o conftest.S conftest.c > /dev/null 2>&1 ; then
+ ac_cv_have_visibility_builtin_bug=yes
+ else
+ if test `grep -c "@PLT" conftest.S` = 0; then
diff --git a/www/firefox-esr/files/patch-configure.in b/www/firefox-esr/files/patch-configure.in
deleted file mode 100644
index aa16f00016b8..000000000000
--- a/www/firefox-esr/files/patch-configure.in
+++ /dev/null
@@ -1,52 +0,0 @@
---- configure.in.orig 2010-11-04 21:05:18.000000000 +0100
-+++ configure.in 2010-11-09 12:59:28.000000000 +0100
-@@ -3803,19 +3803,21 @@
- AC_CHECK_FUNCS(localtime_r strtok_r)
-
- dnl check for clock_gettime(), the CLOCK_MONOTONIC clock, and -lrt
--_SAVE_LDFLAGS=$LDFLAGS
--LDFLAGS="$LDFLAGS -lrt"
--AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC) and -lrt,
-+_SAVE_LIBS=$LIBS
-+AC_SEARCH_LIBS(clock_gettime, rt)
-+AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC),
- ac_cv_have_clock_monotonic,
- [AC_TRY_LINK([#include <time.h>],
- [ struct timespec ts;
- clock_gettime(CLOCK_MONOTONIC, &ts); ],
- ac_cv_have_clock_monotonic=yes,
- ac_cv_have_clock_monotonic=no)])
--LDFLAGS=$_SAVE_LDFLAGS
-+LIBS=$_SAVE_LIBS
- if test "$ac_cv_have_clock_monotonic" = "yes"; then
- HAVE_CLOCK_MONOTONIC=1
-- REALTIME_LIBS=-lrt
-+ if test "$ac_cv_search_clock_gettime" != "none required"; then
-+ REALTIME_LIBS=$ac_cv_search_clock_gettime
-+ fi
- AC_DEFINE(HAVE_CLOCK_MONOTONIC)
- AC_SUBST(HAVE_CLOCK_MONOTONIC)
- AC_SUBST(REALTIME_LIBS)
-@@ -4230,6 +4233,9 @@
- if test -z "$LIBEVENT_DIR" -o "$LIBEVENT_DIR" = no; then
- MOZ_NATIVE_LIBEVENT=
- else
-+PKG_CHECK_MODULES(MOZ_LIBEVENT, libevent,
-+ [MOZ_NATIVE_LIBEVENT=1
-+ MOZ_LIBEVENT_INCLUDES="$MOZ_LIBEVENT_CFLAGS"], [
- if test "${LIBEVENT_DIR}" = "yes"; then
- LIBEVENT_DIR=/usr
- fi
-@@ -4242,10 +4248,11 @@ else
- AC_MSG_ERROR([--with-system-libevent requested but event.h not found]))
- AC_CHECK_LIB(event, event_init,
- [MOZ_NATIVE_LIBEVENT=1
-- MOZ_LIBEVENT_INCLUDES="${LIBEVENT_DIR}/include"
-+ MOZ_LIBEVENT_INCLUDES="-I${LIBEVENT_DIR}/include"
- MOZ_LIBEVENT_LIBS="-L${LIBEVENT_DIR}/lib -levent"],
- [MOZ_NATIVE_LIBEVENT= MOZ_LIBEVENT_INCLUDES= MOZ_LIBEVENT_LIBS=])
- fi
-+])
- CFLAGS=$_SAVE_CFLAGS
- LDFLAGS=$_SAVE_LDFLAGS
- LIBS=$_SAVE_LIBS
diff --git a/www/firefox-esr/files/patch-ipc-chromium-Makefile.in b/www/firefox-esr/files/patch-ipc-chromium-Makefile.in
index bba9d0124037..b660c3662bb0 100644
--- a/www/firefox-esr/files/patch-ipc-chromium-Makefile.in
+++ b/www/firefox-esr/files/patch-ipc-chromium-Makefile.in
@@ -22,7 +22,7 @@
-# message_pump_libevent.cc includes third_party/libevent/event.h,
-# which we put in $(DIST), see export rule below
-LOCAL_INCLUDES += -I$(DIST)
-+LOCAL_INCLUDES += $(filter %/compat, $(MOZ_LIBEVENT_INCLUDES))
++LOCAL_INCLUDES += $(filter %/compat, $(MOZ_LIBEVENT_CFLAGS))
endif # }
vpath %.cc \
diff --git a/www/firefox-esr/files/patch-js-src-configure.in b/www/firefox-esr/files/patch-js-src-configure.in
index ac49f4fef3d9..fc8e66185a87 100644
--- a/www/firefox-esr/files/patch-js-src-configure.in
+++ b/www/firefox-esr/files/patch-js-src-configure.in
@@ -1,21 +1,5 @@
--- js/src/configure.in.orig 2012-01-29 11:24:33.000000000 +0100
+++ js/src/configure.in 2012-01-30 23:30:02.051087215 +0100
-@@ -2732,6 +2742,7 @@
- AC_DEFINE(JS_NUNBOX32)
- ;;
- sparc*-*)
-+ if test ! "$HAVE_64BIT_OS" ; then
- NANOJIT_ARCH=Sparc
- ENABLE_METHODJIT=1
- ENABLE_MONOIC=1
-@@ -2739,6 +2750,7 @@
- ENABLE_METHODJIT_TYPED_ARRAY=1
- AC_DEFINE(JS_CPU_SPARC)
- AC_DEFINE(JS_NUNBOX32)
-+ fi
- ;;
- esac
-
@@ -5946,6 +5946,7 @@ _EGREP_PATTERN="${_EGREP_PATTERN}dummy_n
* C++ implementations should define these macros only when __STDC_LIMIT_MACROS
* is defined before <stdint.h> is included. */