aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-06-03 09:10:33 +0800
committermarcus <marcus@FreeBSD.org>2003-06-03 09:10:33 +0800
commit023d3d1fa8036282a305a2c1d904d9fe45c8027d (patch)
tree67ea0c659bf592acaf8acacfa11c5ddeff6365a5 /www/firefox-esr
parent337525ca604cffcf9bc6f21e56db3dbcb10fa758 (diff)
downloadfreebsd-ports-gnome-023d3d1fa8036282a305a2c1d904d9fe45c8027d.tar.gz
freebsd-ports-gnome-023d3d1fa8036282a305a2c1d904d9fe45c8027d.tar.zst
freebsd-ports-gnome-023d3d1fa8036282a305a2c1d904d9fe45c8027d.zip
Use ${PERL5} to properly locate perl.
Submitted by: perky
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox-esr/files/mozconfig.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index ccc53c96d9ae..aea22c49a05b 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -101,6 +101,7 @@ post-extract::
-e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
-e 's|@PREFIX@|${LOCAL_PREFIX}|' \
+ -e 's|@PERL@|${PERL5}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
post-patch:
diff --git a/www/firefox-esr/files/mozconfig.in b/www/firefox-esr/files/mozconfig.in
index ed139738e9d5..66f0897780b1 100644
--- a/www/firefox-esr/files/mozconfig.in
+++ b/www/firefox-esr/files/mozconfig.in
@@ -18,7 +18,7 @@ export LDFLAGS="@LDFLAGS@"
export CONFIG_SH=/bin/sh
export XP_UNIX=1
mk_add_options XP_UNIX=1
-export PERL=/usr/local/bin/perl
+export PERL="@PERL@"
mk_add_options PERL=$PERL
# Configure options for installation
ac_add_options --prefix=@PREFIX@