aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-11 15:31:45 +0800
committermarcus <marcus@FreeBSD.org>2004-02-11 15:31:45 +0800
commit59092beba681e3aa350a5867d91b36ea2572f54b (patch)
treebd8a607b5ee27414df4b1242450c7eab966acf32 /www/firefox-esr
parentb9bbbb01f8ea58ed0a03a9240f45b362d77abf1c (diff)
downloadfreebsd-ports-gnome-59092beba681e3aa350a5867d91b36ea2572f54b.tar.gz
freebsd-ports-gnome-59092beba681e3aa350a5867d91b36ea2572f54b.tar.zst
freebsd-ports-gnome-59092beba681e3aa350a5867d91b36ea2572f54b.zip
* Import the JPI_LIST changes from www/mozilla so that multiple JPI versions
will be tried. There is one addition, though. JPI_LIST is now overrideable. [1] * Remove the bit about Perl version from pkg-message. We support all versions of Perl now. Requested by: ale
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile19
-rw-r--r--www/firefox-esr/pkg-message2
2 files changed, 15 insertions, 6 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index b53bed5c40ed..fa30a6eb63a5 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -28,7 +28,6 @@ CONFIGURE_ENV= WITH_GTK2=yes
FAKEDIR= ${WRKDIR}/fake
FAKESUBDIR= ${FAKEDIR}/lib/${PORTNAME}
HAS_CONFIGURE= yes
-JREDIR= ${LOCALBASE}/jdk1.3.1/jre
ESD_LIB= libesd.so.2
LOCAL_PREFIX= ${PREFIX}/lib/${PORTNAME}
NO_MTREE= yes
@@ -43,6 +42,12 @@ USE_REINPLACE= yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
+JPI_LIST?=\
+ ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
+
OPTIONS= DEBUG "Build a debugging image" off \
HEADERS "Install headers and IDL files" off \
LOGGING "Enable additional log messages" off \
@@ -149,8 +154,14 @@ post-install:
${LN} -sf ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/firefox-config
${RM} -f ${PLUGINSDIR}/libjavaplugin_oji.so
- -${LN} -sf \
- ${JREDIR}/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
- ${PLUGINSDIR}/libjavaplugin_oji.so
+ if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
+ for jpi in ${JPI_LIST}; do \
+ if [ -f $${jpi} ]; then \
+ -${LN} -sf $${jpi} \
+ ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ; \
+ break; \
+ fi; \
+ done; \
+ fi
.include <bsd.port.post.mk>
diff --git a/www/firefox-esr/pkg-message b/www/firefox-esr/pkg-message
index 507a61e48136..ed9bc51041fc 100644
--- a/www/firefox-esr/pkg-message
+++ b/www/firefox-esr/pkg-message
@@ -7,8 +7,6 @@ bug reports to any other addresses.
Please include the following information with any bug report:
* Output from 'uname -a'.
* Date/time stamp from www/firefox/Makefile.
-* Perl version used (/usr/bin/perl --version or
- /usr/local/bin/perl --version for -current).
* Where/when did the problem occur: configuring, building, or
running firefox
* How can you reproduce the problem?