aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-11-08 01:56:33 +0800
committeralane <alane@FreeBSD.org>2002-11-08 01:56:33 +0800
commit199d4bdc55bbc12e66a43c371f9051b6c42be3c0 (patch)
tree7183555ecaf64633d99416e4cd6850775d32c4a1 /www/firefox/Makefile
parent80c578f5cbc7702d259b08e27808096e73fc3a4a (diff)
downloadfreebsd-ports-gnome-199d4bdc55bbc12e66a43c371f9051b6c42be3c0.tar.gz
freebsd-ports-gnome-199d4bdc55bbc12e66a43c371f9051b6c42be3c0.tar.zst
freebsd-ports-gnome-199d4bdc55bbc12e66a43c371f9051b6c42be3c0.zip
1. Broken for system perl. Sorry but we don't know yet how to make it work.
2. Disable javascript debugger (like we're at a stage where we want to do that .... hahaha). 3. Remove dupes from files/mozconfig.in. 4. Whack the share and include dirs in a post-install target (I know it's slower that way, but I'm gonna let Trevor work out how to do it otherwise, since he so kindly volunteered.) 5. We need an icon for this, people. Any graphics geeks out there? Thanks to Adam Weinberger for his valuable info about perl versions, and his continuing research. Thanks to everybody else who's tested, even if y'all did report the same thing. 8-) Finally, thanks to Warren Zevon, whose song My ****'s ****ed Up certainly applies to the early stages of this port.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile36
1 files changed, 24 insertions, 12 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 98aaabe776bc..19822b696a6d 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -9,12 +9,12 @@
PORTNAME= phoenix
PORTVERSION= 0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www # pita
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
-MAINTAINER= phoenix@geeksrus.net # alane@fbsd and trevor@fbsd
+MAINTAINER= phoenix@freebsd.org # alane@fbsd and trevor@fbsd
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -22,7 +22,7 @@ LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2 \
IDL.2:${PORTSDIR}/devel/ORBit \
- Xft2.2:${PORTSDIR}/x11-fonts/Xft
+ Xft2.2:${PORTSDIR}/x11-fonts/Xft
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
@@ -49,6 +49,7 @@ MAKE_ARGS+= XP_UNIX=1
.include <bsd.port.pre.mk>
+.if !defined(PERL_LEVEL)
perl_major=${PERL_VERSION:C|^([1-9]+).*|\1|}
_perl_minor=00${PERL_VERSION:C|^([1-9]+)\.([0-9]+).*|\2|}
perl_minor=${_perl_minor:C|^.*(...)|\1|}
@@ -60,23 +61,32 @@ _perl_patch=0${PERL_VERSION:C|^([1-9]+)\.([0-9]+)\.*|0|}
perl_patch=${_perl_patch:C|^.*(..)|\1|}
.endif # ${perl_minor} < 100
PERL_LEVEL=${perl_major}${perl_minor}${perl_patch}
+.endif # !defined(PERL_LEVEL)
SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-.if ${PERL_LEVEL} < 500601
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif # ${PERL_LEVEL} < 500601
-
.if ${OSVERSION} > 500038
-BROKEN= "on -CURRENT, can only be used with local files."
-BROKEN+="Make with -DNO_IGNORE to override this message."
+
+BROKEN= "on -CURRENT, can only be used with local files. You can run"
+BROKEN+="make with -DNO_IGNORE to override this message"
+
.endif
-pre-extract:
+.if ${PERL_LEVEL} < 500601
+.undef NO_IGNORE
+BROKEN= "right now, we can only support the ports versions of Perl."
+BROKEN+="We are working on the problem. Sorry for the inconvenience."
+BROKEN+="If you have installed a Perl port, and are getting this message,"
+BROKEN+="please make sure you have issued the command 'use.perl port'"
+
+.endif # ${PERL_LEVEL} < 500601
+
+pre-extract::
+ @${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
+ @${ECHO_MSG}
-post-extract:
+post-extract::
@${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
-e 's|@X11BASE@|${X11BASE}|' \
@@ -99,6 +109,8 @@ post-install:
@${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/phoenix-config
@${CAT} ${PKGMESSAGE} 2>/dev/null; sleep 5
+ @${RM} -fr ${LOCAL_PREFIX}/share
+ @${RM} -fr ${LOCAL_PREFIX}/include
.include <bsd.port.post.mk>