aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-11-01 20:41:01 +0800
committeralane <alane@FreeBSD.org>2002-11-01 20:41:01 +0800
commit22468f4928c00827a0e0c0ee0e2de4f127686529 (patch)
tree52a502b9b8e445c64e38b4a3596bf0a2814187c6 /www/firefox/Makefile
parent2fea390f73b20336a187cc9de247e604024b9104 (diff)
downloadfreebsd-ports-gnome-22468f4928c00827a0e0c0ee0e2de4f127686529.tar.gz
freebsd-ports-gnome-22468f4928c00827a0e0c0ee0e2de4f127686529.tar.zst
freebsd-ports-gnome-22468f4928c00827a0e0c0ee0e2de4f127686529.zip
1. PORTREVISION -> 1.
2. Incorporated my uncommited mods with Trevor's changes. 3. Remade pkg-plist accordingly. 4. Use /usr/bin/perl if present, then /usr/local/bin/perl. 5. Add File::Spec to BUILD_DEPENDS if perl < 5.8.0.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 227b008f88ed..abae5aa838f5 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -9,6 +9,7 @@
PORTNAME= phoenix
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
@@ -30,12 +31,12 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
-#USE_AUTOCONF_VER= 213
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
USE_GNOMENG= yes
-USE_GNOME= gtk12 ORBit
+USE_GNOME= gtk12 orbit
CFLAGS+= ${PTHREAD_CFLAGS}
LIBS+= ${PTHREAD_LIBS}
@@ -55,8 +56,8 @@ PERL_MAJOR=${PERL_VER:C|^([1-9]+).*|\1|}
PERL_MINOR=${PERL_VER:C|^[1-9]+\.0*([1-9]+).*|\1|}
.if ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS= ${BUILD_DEPENDS}
.endif # ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
.if ${OSVERSION} > 500038
@@ -78,8 +79,10 @@ post-patch:
nsDrawingSurfaceGTK.cpp nsFontMetricsXft.h
post-install:
+ ${RM} ${PREFIX}/bin/phoenix
${LN} -s ${LOCAL_PREFIX}/bin/phoenix \
${PREFIX}/bin/phoenix
+ ${RM} ${PREFIX}/bin/phoenix-config
${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/phoenix-config