aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2004-02-12 06:02:15 +0800
committertrevor <trevor@FreeBSD.org>2004-02-12 06:02:15 +0800
commit2a2a26bb9a92bceb31451b03a8ee4a1f05b76ea2 (patch)
treeb0643e3d5bb0fc0cdaf2750b770db5704fce46eb /www/firefox/Makefile
parent99514a8907d332aaa5faebceb0e53451b7e782e8 (diff)
downloadfreebsd-ports-gnome-2a2a26bb9a92bceb31451b03a8ee4a1f05b76ea2.tar.gz
freebsd-ports-gnome-2a2a26bb9a92bceb31451b03a8ee4a1f05b76ea2.tar.zst
freebsd-ports-gnome-2a2a26bb9a92bceb31451b03a8ee4a1f05b76ea2.zip
Add comments explaining the installation process.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install: