aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-06 03:53:30 +0800
committermarcus <marcus@FreeBSD.org>2004-08-06 03:53:30 +0800
commit54cc9169654c19c9fca5badc0b1fa9a8a5f52827 (patch)
tree46670567bfefb650a84618136a516b29f63778ef /www/firefox/Makefile
parentca0733fafb887770478b8c4d34c7a2118caebb5e (diff)
downloadfreebsd-ports-gnome-54cc9169654c19c9fca5badc0b1fa9a8a5f52827.tar.gz
freebsd-ports-gnome-54cc9169654c19c9fca5badc0b1fa9a8a5f52827.tar.zst
freebsd-ports-gnome-54cc9169654c19c9fca5badc0b1fa9a8a5f52827.zip
Update to 0.9.3 to fix a few security issues:
http://bugzilla.mozilla.org/buglist.cgi?bug_id=251381,249004,250906,253121 Also, add a pkg-deinstall script to remove the auto-generated registry files. PR: 70031
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 5eeeb7b36085..4cf8da901bc2 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= firefox
-PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTVERSION= 0.9.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
@@ -42,6 +41,7 @@ USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
mozilla-nspr mozilla-nss mozilla-plugin
@@ -171,6 +171,8 @@ pre-install:
${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/extensions.port
@${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
+ < ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
.if !defined (WITH_HEADERS)
@${RM} -fr ${FAKEDIR}/share/idl ${FAKEDIR}/include