aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-16 14:58:10 +0800
committermarcus <marcus@FreeBSD.org>2004-06-16 14:58:10 +0800
commit73d78e1e1bb280ef341bd39ce4b20754d7c01c80 (patch)
treef25ebfa500ffad86bbbb0112915d333c14c44e1a /www/firefox/Makefile
parenta95bd833b8a7a6a2feb9f495bd4de80725e358ce (diff)
downloadfreebsd-ports-gnome-73d78e1e1bb280ef341bd39ce4b20754d7c01c80.tar.gz
freebsd-ports-gnome-73d78e1e1bb280ef341bd39ce4b20754d7c01c80.tar.zst
freebsd-ports-gnome-73d78e1e1bb280ef341bd39ce4b20754d7c01c80.zip
Fix a typo in the pkg-install script, and add a hack so that firefox does not
need to be run as root before running it as other users.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index a05f72056f59..fe0f3114bcdb 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -177,7 +177,9 @@ do-install:
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
.for i in ${EXTRA_SCRIPTS}
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
.endfor