aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-25 00:33:53 +0800
committermarcus <marcus@FreeBSD.org>2004-06-25 00:33:53 +0800
commit9f09bd8a3fc8706c7b6df28cce71f3fd1b22df80 (patch)
treee0713fb9689db7ee07ff16ae662f5d2e2958553e /www/firefox/Makefile
parent7df7a10a573c4edeb59714e97584fb0a1afb1c57 (diff)
downloadfreebsd-ports-gnome-9f09bd8a3fc8706c7b6df28cce71f3fd1b22df80.tar.gz
freebsd-ports-gnome-9f09bd8a3fc8706c7b6df28cce71f3fd1b22df80.tar.zst
freebsd-ports-gnome-9f09bd8a3fc8706c7b6df28cce71f3fd1b22df80.zip
* Add optional support for gnome-vfs support (e.g. smb:// and sftp:// URLs) [1]
* Fix a problem with the pkg-config files referencing mozilla components and not firefox components PR: 68221 [1] Submitted by: Tom McLaughlin <tmclaugh@sdf.lonestar.org> [1]
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 1d30ff57a4a3..d9033fcf7dc5 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
@@ -43,6 +43,9 @@ USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
PKGINSTALL= ${WRKDIR}/pkg-install
+PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
+ mozilla-nspr mozilla-nss mozilla-plugin
+
JPI_LIST?=\
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
@@ -53,7 +56,8 @@ OPTIONS= DEBUG "Build a debugging image" off \
HEADERS "Install headers and IDL files" off \
LOGGING "Enable additional log messages" off \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
- XFT "Enable support for anti-aliased fonts" on
+ XFT "Enable support for anti-aliased fonts" on \
+ SMB "Enable smb:// URI support using gnomevfs" off
.include <bsd.port.pre.mk>
@@ -79,6 +83,11 @@ CONFIGURE_ENV+= WITHOUT_XFT=yes
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
.endif # !defined(WITHOUT_XFT)
+.if defined(WITH_SMB)
+USE_GNOME+= gnomevfs2
+CONFIGURE_ENV+= WITH_SMB=yes
+.endif # defined(WITH_SMB)
+
CPPFLAGS+= -I${X11BASE}/include -I${LOCALBASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= -L${X11BASE}/lib
@@ -128,6 +137,10 @@ post-patch:
${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+.for ii in ${PKGCONFIG_FILES}
+ @${PERL} -pi -e 's|mozilla-|firefox-|g' \
+ ${WRKSRC}/build/unix/${ii}.pc.in
+.endfor
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \