aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-10-22 02:37:12 +0800
committeralane <alane@FreeBSD.org>2002-10-22 02:37:12 +0800
commitc49dfed632f9e47f739ef274bb1afcef4f0e1ebf (patch)
tree97c97ee8ed795e42878cf9251b2f560183ee69b0 /www/firefox/Makefile
parenta19913e985584044372a9255c5c48ee15520d443 (diff)
downloadfreebsd-ports-gnome-c49dfed632f9e47f739ef274bb1afcef4f0e1ebf.tar.gz
freebsd-ports-gnome-c49dfed632f9e47f739ef274bb1afcef4f0e1ebf.tar.zst
freebsd-ports-gnome-c49dfed632f9e47f739ef274bb1afcef4f0e1ebf.zip
First working version of port. Needs testing and cleanup, probably move
over to /usr/X11R6 (or not), but it's a start. And it's *fast*.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 6663e46fa276..8de59bf092bc 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -8,27 +8,37 @@
#
PORTNAME= phoenix
-PORTVERSION= 0.3.20021021
+PORTVERSION= 0.3
PORTREVISION= 0
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= alane
+MASTER_SITE_SUBDIR= trevor
MAINTAINER= alane@freebsd.org # will change to trevor@ soon
-.if !defined(RING_OF_FIRE)
-.undef NO_IGNORE
-BORKED= This is a work in progress.
-BROKEN= ${BORKED}
-FORBIDDEN= ${BORKED}
-.endif # !defined(RING_OF_FIRE)
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ freetype-config:${PORTSDIR}/print/freetype2 \
+ perl5.8.0:${PORTSDIR}/lang/perl5.8
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ mng.1:${PORTSDIR}/graphics/libmng \
+ freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 213
+#USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/mozilla
+
.include <bsd.port.pre.mk>
+
+post-extract:
+ ${SED} -e 's|@X11BASE@|${X11BASE}|' \
+ -e 's|@LOCALBASE@|${LOCALBASE}|' \
+ <${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+
.include <bsd.port.post.mk>
#EOF