aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-12-13 17:41:38 +0800
committeralane <alane@FreeBSD.org>2002-12-13 17:41:38 +0800
commitd69ed97a6fae059eeec4f0ddb724acee25b23b83 (patch)
tree8a0f558ab70e79caeee642aaec8832d57ea152a6 /www/firefox/Makefile
parentc74086d353e57e0c9c29fa65f22b7b882dbb7986 (diff)
downloadfreebsd-ports-gnome-d69ed97a6fae059eeec4f0ddb724acee25b23b83.tar.gz
freebsd-ports-gnome-d69ed97a6fae059eeec4f0ddb724acee25b23b83.tar.zst
freebsd-ports-gnome-d69ed97a6fae059eeec4f0ddb724acee25b23b83.zip
Finally, a release Phoenix that works and does not crash all the time.
Approved by: kris (a long time ago)
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile39
1 files changed, 27 insertions, 12 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 4737767c1d58..87ad5278d832 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -8,11 +8,11 @@
#
PORTNAME= phoenix
-PORTVERSION= 0.4
-PORTREVISION= 10
+PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= www # pita
-MASTER_SITES= ${MASTER_SITE_LOCAL} # ${BSD_WEBDIR}
-MASTER_SITE_SUBDIR= trevor
+MASTER_SITES= ${MASTER_SITE_LOCAL} ${BSD_WEBDIR}
+MASTER_SITE_SUBDIR= alane
MAINTAINER= phoenix@freebsd.org # alane@fbsd and trevor@fbsd
@@ -39,18 +39,12 @@ HAS_CONFIGURE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 orbit
-CPPFLAGS+= -I${X11BASE}/include
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${X11BASE}/lib
-LIBS+= ${PTHREAD_LIBS}
-
NO_MTREE= yes
WRKSRC= ${WRKDIR}/mozilla
LOCAL_SUBDIR= lib/${PORTNAME}
LOCAL_PREFIX= ${PREFIX}/${LOCAL_SUBDIR}
JREDIR= ${LOCALBASE}/jdk1.3.1/jre
-MOZVER= 1.2b
-#MOZVER= 1.3a
+MOZVER= 1.3a
PLUGINSDIR= ${LOCAL_PREFIX}/lib/mozilla-${MOZVER}/plugins/
.include <bsd.port.pre.mk>
@@ -65,6 +59,21 @@ BROKEN+="please make sure you have issued the command 'use.perl port'"
SORT?=/usr/bin/sort
PLIST=${WRKDIR}/plist
+.if defined(WITH_DEBUG)
+WITHOUT_OPTIMIZE= yes
+CONFIGURE_ENV+= WITH_DEBUG=yes
+.endif # defined(WITH_DEBUG)
+
+.if !defined(WITHOUT_OPTIMIZE)
+CFLAGS+= -O2
+.endif # defined(WITH_OPTIMIZE)
+
+
+CPPFLAGS+= -I${X11BASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${X11BASE}/lib
+LIBS+= ${PTHREAD_LIBS}
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
@@ -130,6 +139,12 @@ cons-plist:
.include <bsd.port.post.mk>
-generate-plist: link-bins link-java cleanup-install cons-plist
+# <alane>
+# Under normal circumstances, you should not put anything after
+# the above line. However, this is the only way I can state the
+# dependency without trashing the actual code of the generate-plist
+# target. This is a limitation of the make(1) program itself.
+# </alane>
+generate-plist: link-bins cleanup-install cons-plist
#EOF