aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-10-22 17:26:56 +0800
committeralane <alane@FreeBSD.org>2002-10-22 17:26:56 +0800
commitd8cb330e7903d3d74b69f3a8b302a284a89c35d3 (patch)
tree9ed417a3749a3d5213a5e12cfc1ab6fd302cbc0c /www/firefox/Makefile
parent731fcd931157b889db0937b1dfa7b357e64a2f83 (diff)
downloadfreebsd-ports-gnome-d8cb330e7903d3d74b69f3a8b302a284a89c35d3.tar.gz
freebsd-ports-gnome-d8cb330e7903d3d74b69f3a8b302a284a89c35d3.tar.zst
freebsd-ports-gnome-d8cb330e7903d3d74b69f3a8b302a284a89c35d3.zip
1. Expanded configure/make options in files/mozconfig.in.
* Fixed problem with reliably finding perl 5.8.0. * Made build faster. * Shut up most of the compiler warnings (turned off --pedantic). * Strip the binaries. * Saved 2 meg on size of binary package (16M -> 14M). 2. Moved install to ${X11BASE}/lib/phoenix to keep it out of the way of mozilla, since it uses the same namespace for dirs/files. 3. Link bin/phoenix and bin/phoenix.config into install tree's bin dir. TO DO: make installation smaller. make distfile smaller. test,test,test.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 8de59bf092bc..a197d83f1ecb 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -9,22 +9,24 @@
PORTNAME= phoenix
PORTVERSION= 0.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
-MAINTAINER= alane@freebsd.org # will change to trevor@ soon
-
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- freetype-config:${PORTSDIR}/print/freetype2 \
- perl5.8.0:${PORTSDIR}/lang/perl5.8
+MAINTAINER= alane@freebsd.org # and trevor@freebsd.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ freetype-config:${PORTSDIR}/print/freetype2 \
+ perl5.8.0:${PORTSDIR}/lang/perl5.8
+
+PREFIX= ${X11BASE}/lib/${PORTNAME}
+
USE_BZIP2= yes
USE_GMAKE= yes
#USE_AUTOCONF_VER= 213
@@ -34,11 +36,19 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != 5.8.0
+.error This port requires Perl 5.8.0.
+.endif
+
post-extract:
${SED} -e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+post-install:
+ ${LN} -s ${PREFIX}/bin/phoenix ${X11BASE}/bin/phoenix
+ ${LN} -s ${PREFIX}/bin/mozilla-config ${X11BASE}/bin/phoenix-config
+
.include <bsd.port.post.mk>
#EOF