aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-10-10 03:44:02 +0800
committermarcus <marcus@FreeBSD.org>2005-10-10 03:44:02 +0800
commitefe59070b379f0b80a99e3f52a883088aa2f68ce (patch)
tree0a42c3c373e151262aa0dec0ef30353b67f96c60 /www/firefox/Makefile
parent634dee5985c68e2009ee609217373114257ba0de (diff)
downloadfreebsd-ports-gnome-efe59070b379f0b80a99e3f52a883088aa2f68ce.tar.gz
freebsd-ports-gnome-efe59070b379f0b80a99e3f52a883088aa2f68ce.tar.zst
freebsd-ports-gnome-efe59070b379f0b80a99e3f52a883088aa2f68ce.zip
* Add support of ports-installed Kerberos [1]
* Enable all default extensions [2] PR: 86961 [2] Submitted by: David W. Hankins <David_Hankins@isc.org> [1]
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 4d6386d1e28c..857f950a868b 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= firefox
PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -40,6 +40,7 @@ USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+KRB5_HOME?= /usr
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -145,6 +146,7 @@ post-extract::
-e 's|@LOCALBASE@|${LOCALBASE}|' \
-e 's|@FAKEDIR@|${FAKEDIR}|' \
-e 's|@PERL@|${PERL5}|' \
+ -e 's|@KRB5_HOME@|${KRB5_HOME}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
@${SED} -e 's|@PORTNAME_ICON@|${PORTNAME_ICON}|' \
<${FILESDIR}/${PORTNAME}.desktop.in >${WRKDIR}/${PORTNAME}.desktop