aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-10-22 19:04:48 +0800
committeralane <alane@FreeBSD.org>2002-10-22 19:04:48 +0800
commitf2d1033449858d5e2882717ff5f8d45955817002 (patch)
tree6e09e3886009c8c0dc19518b98ec1235f3190f39 /www/firefox/Makefile
parentc927b08d317ba16f70d7eac5fe8eeaa0b39db234 (diff)
downloadfreebsd-ports-gnome-f2d1033449858d5e2882717ff5f8d45955817002.tar.gz
freebsd-ports-gnome-f2d1033449858d5e2882717ff5f8d45955817002.tar.zst
freebsd-ports-gnome-f2d1033449858d5e2882717ff5f8d45955817002.zip
1. Respect CFLAGS.
2. Set appropriate compile/link options for threading.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index a197d83f1ecb..ce27e02cae11 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -31,7 +31,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
#USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
-
+CFLAGS+= ${PTHREAD_CFLAGS}
+LIBS+= ${PTHREAD_LIBS}
WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
@@ -41,7 +42,9 @@ WRKSRC= ${WRKDIR}/mozilla
.endif
post-extract:
- ${SED} -e 's|@X11BASE@|${X11BASE}|' \
+ ${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
+ -e 's|@LIBS@|${LIBS}|' \
+ -e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig