aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-14 04:12:09 +0800
committermarcus <marcus@FreeBSD.org>2004-02-14 04:12:09 +0800
commitf4259a5899dccf9688587499316f8e1a70a7c5ce (patch)
treeaa5494f9c699249e5d8f946fe74cacdcba389070 /www/firefox/Makefile
parentee58766244004f6b958436903ec4547f9934a6a1 (diff)
downloadfreebsd-ports-gnome-f4259a5899dccf9688587499316f8e1a70a7c5ce.tar.gz
freebsd-ports-gnome-f4259a5899dccf9688587499316f8e1a70a7c5ce.tar.zst
freebsd-ports-gnome-f4259a5899dccf9688587499316f8e1a70a7c5ce.zip
Fix up the port-install substitutions so that we operate on the correct files.
Reported by: Franz Klammer <klammer@webonaut.com>
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 90c95bf19f59..b94136056028 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -166,12 +166,12 @@ post-install:
.for ii in f F
${RM} -f ${PREFIX}/bin/${ii}irefox
${LN} -sf ${LOCAL_PREFIX}/bin/firefox ${PREFIX}/bin/${ii}irefox
- ${PERL} -pi -e 's|${FAKEDIR}|${PREFIX}|g' ${LOCAL_PREFIX}/bin/${ii}irefox
.endfor
+ ${PERL} -pi -e 's|${FAKEDIR}|${PREFIX}|g' ${LOCAL_PREFIX}/bin/firefox
${RM} -f ${PREFIX}/bin/firefox-config
${LN} -sf ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/firefox-config
- ${PERL} -pi -e 's|${FAKEDIR}|${PREFIX}|g' ${LOCAL_PREFIX}/bin/firefox-config
+ ${PERL} -pi -e 's|${FAKEDIR}|${PREFIX}|g' ${LOCAL_PREFIX}/bin/mozilla-config
${FIND} ${LOCAL_PREFIX}/lib/pkgconfig -type f | ${XARGS} ${PERL} -pi -e \
's|${FAKEDIR}|${PREFIX}|g'
-if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \