aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authormarcel <marcel@FreeBSD.org>2009-03-22 02:51:50 +0800
committermarcel <marcel@FreeBSD.org>2009-03-22 02:51:50 +0800
commitf75f89ce9c4e58b5702e186e954f587d9ec5d5b0 (patch)
treebfcc30e702cd4817f2fce4c881ea6277daa7e9d1 /www/firefox/Makefile
parentd528a1f4fa063a74a71269dd66aa9aca46b5dbf7 (diff)
downloadfreebsd-ports-gnome-f75f89ce9c4e58b5702e186e954f587d9ec5d5b0.tar.gz
freebsd-ports-gnome-f75f89ce9c4e58b5702e186e954f587d9ec5d5b0.tar.zst
freebsd-ports-gnome-f75f89ce9c4e58b5702e186e954f587d9ec5d5b0.zip
grep for 'pthread:' in the compiler's spec file to avoid matching
random references of 'pthread'. On powerpc the mfwrap production mentions "pthread_create", which matched the RE. Ok'd by: marcus (thanks!)
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 767a533671dc..98a2ca68ad91 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -51,7 +51,7 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
+GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread: | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui