aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-09 03:37:12 +0800
committermarcus <marcus@FreeBSD.org>2004-02-09 03:37:12 +0800
commit0f11da81658af4e419757abbac620f68d7a07a3f (patch)
treed62d7f6877a72d9b66915b685dd9202f2fd46ecb /www/firefox/Makefile
parent219bd87971232ea6354dba025474cdd3bbf3d4b5 (diff)
downloadfreebsd-ports-gnome-0f11da81658af4e419757abbac620f68d7a07a3f.tar.gz
freebsd-ports-gnome-0f11da81658af4e419757abbac620f68d7a07a3f.tar.zst
freebsd-ports-gnome-0f11da81658af4e419757abbac620f68d7a07a3f.zip
* Fix a bug where Firebird would lock up after typing any text. This had to
do with esound being installed, but not being used (e.g. when not running under the GNOME Desktop). What happens now is sound support is disabled by default. If you wish to enable Type Ahead Find sound support, edit your prefs.js file, and add: user_pref("accessibility.typeaheadfind.enablesound", true); * Make portlint happy by not including anything after bsd.port.post.mk * Clean up the pkg-message a bit to reflect reality with respect to Perl Thanks to casaveli on BSDForums for finding it was esound causing the lock up as well as testing the patch mentioned above.
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile32
1 files changed, 9 insertions, 23 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 08357740e94d..e45a1d84d60c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firebird
PORTVERSION= 0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= firebird/releases/${PORTVERSION}
@@ -21,7 +21,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2 \
- iconv.3:${PORTSDIR}/converters/libiconv \
nspr4.1:${PORTSDIR}/devel/nspr
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
@@ -30,6 +29,7 @@ CONFIGURE_ENV= WITH_GTK2=yes
USE_X_PREFIX= yes
ALL_TARGET= default
+USE_ICONV= yes
USE_GMAKE= yes
USE_GNOME= gtk20 libidl
USE_PERL5= yes
@@ -108,17 +108,19 @@ post-patch:
${WRKSRC}/security/coreconf/FreeBSD.mk \
${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
${WRKSRC}/js/src/Makefile.in
+ @${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
+ ${WRKSRC}/modules/libpref/src/init/all.js \
+ ${WRKSRC}/browser/app/profile/all.js \
+ ${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
${RM} -fr ${LOCAL_PREFIX}
-${MKDIR} ${PLUGINSDIR}
-install-extra:
+post-install:
.for i in ${EXTRA_SCRIPTS}
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
.endfor # i in ${EXTRA_SCRIPTS}
-
-link-bins:
${RM} -f ${PREFIX}/bin/firebird
${LN} -s ${LOCAL_PREFIX}/bin/MozillaFirebird \
${PREFIX}/bin/firebird
@@ -128,14 +130,10 @@ link-bins:
${RM} -f ${PREFIX}/bin/firebird-config
${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/firebird-config
-
-link-java:
-${RM} -f ${PLUGINSDIR}/libjavaplugin_oji.so
-${LN} -sf \
- ${JREDIR}/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
- ${PLUGINSDIR}/libjavaplugin_oji.so
-
-cleanup-install:
+ ${JREDIR}/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
+ ${PLUGINSDIR}/libjavaplugin_oji.so
${RM} -fr ${LOCAL_PREFIX}/share/idl
${RM} -fr ${LOCAL_PREFIX}/include
@@ -159,16 +157,4 @@ cons-plist:
${FIND} ${LOCAL_SUBDIR} -type d ! -empty | ${SORT} -r \
| ${SED} -e "s:^:@dirrm :" >> ${PLIST}
-.PHONY: install-extra link-bins link-java cleanup-install cons-plist
-
.include <bsd.port.post.mk>
-
-# <alane>
-# Under normal circumstances, you should not put anything after
-# the above line. However, this is the only way I can state the
-# dependency without trashing the actual code of the generate-plist
-# target. This is a limitation of the make(1) program itself.
-# </alane>
-generate-plist: install-extra link-bins link-java cleanup-install
-
-#EOF