aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox15
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-11-19 00:37:50 +0800
committermarcus <marcus@FreeBSD.org>2004-11-19 00:37:50 +0800
commit25f43038dfb27709913d46cabf2f37cad5ad9baa (patch)
treea111e106d2e3e4d230570226d75a43119cbbe24a /www/firefox15
parent0a35c5fddb0f11e82d1af79723d894c66ba11a24 (diff)
downloadfreebsd-ports-gnome-25f43038dfb27709913d46cabf2f37cad5ad9baa.tar.gz
freebsd-ports-gnome-25f43038dfb27709913d46cabf2f37cad5ad9baa.tar.zst
freebsd-ports-gnome-25f43038dfb27709913d46cabf2f37cad5ad9baa.zip
Instead of using Xvfb, and evil black magic to create the extensions
repository, use the hidden "-register" option instead. This has the advantage of not requiring an X DISPLAY and not modifying any preferences.
Diffstat (limited to 'www/firefox15')
-rw-r--r--www/firefox15/Makefile3
-rw-r--r--www/firefox15/pkg-install.in5
2 files changed, 2 insertions, 6 deletions
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index 906070eefe9a..ec76e0eb1c33 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -21,7 +21,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-RUN_DEPENDS= Xvfb:${X_VFBSERVER_PORT}
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
diff --git a/www/firefox15/pkg-install.in b/www/firefox15/pkg-install.in
index f548cac38445..8f8dbd0c6cc3 100644
--- a/www/firefox15/pkg-install.in
+++ b/www/firefox15/pkg-install.in
@@ -27,9 +27,6 @@ rm -rf ${MOZDIR}/extensions
cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGXPCOM} || true
./run-mozilla.sh ${REGCHROME} || true
-
-# Instantiate the extension space as root.
-su - root -c "env PATH=${PATH} %%X11BASE%%/bin/xinit %%MOZDIR%%/run-mozilla.sh ${FIREFOX} -install-global-extension -- %%X11BASE%%/bin/Xvfb :1001" > /dev/null 2>&1
-su - root -c "env PATH=${PATH} %%X11BASE%%/bin/xinit %%MOZDIR%%/run-mozilla.sh ${FIREFOX} -install-global-theme -- %%X11BASE%%/bin/Xvfb :1001" > /dev/null 2>&1
+./run-mozilla.sh ${FIREFOX} -register > /dev/null 2>&1
exit 0