aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox3-i18n/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-30 13:01:20 +0800
committersat <sat@FreeBSD.org>2006-05-30 13:01:20 +0800
commit4ea9b4cd238aa117badae3119e609bb18730720a (patch)
tree4f138d70710a3fd9ca1c88fbae0f5d4555ae1a90 /www/firefox3-i18n/Makefile
parent1c7cd49b7bbb88bc10b885af62867d93d5b8c872 (diff)
downloadfreebsd-ports-gnome-4ea9b4cd238aa117badae3119e609bb18730720a.tar.gz
freebsd-ports-gnome-4ea9b4cd238aa117badae3119e609bb18730720a.tar.zst
freebsd-ports-gnome-4ea9b4cd238aa117badae3119e609bb18730720a.zip
Add port www/firefox-i18n
Please welcome a one-port-to-rule-them-all localization pack for *firefox browser. It installs most popular languages by default (zh-CN de fr ja ru it es-ES), but you can tune it by setting FIREFOX_I18N in your /etc/make.conf to any other of supported locales or to "all" to install them all. It depends on xpi-locale-switcher extension by default, which makes it very easy to switch between locales (Tools->Languages). Define WITHOUT_SWITCHER to avoid the dependency. Approved by: krion (mentor)
Diffstat (limited to 'www/firefox3-i18n/Makefile')
-rw-r--r--www/firefox3-i18n/Makefile70
1 files changed, 70 insertions, 0 deletions
diff --git a/www/firefox3-i18n/Makefile b/www/firefox3-i18n/Makefile
new file mode 100644
index 000000000000..86080e18a1b0
--- /dev/null
+++ b/www/firefox3-i18n/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: firefox-i18n
+# Date created: 28 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= firefox-i18n
+PORTVERSION= 1.5.0.3
+CATEGORIES= www
+MASTER_SITE_SUBDIR= firefox/releases/${PORTVERSION}/linux-i686/xpi
+PKGNAMEPREFIX=
+DISTFILES= ${FIREFOX_I18N:S/$/.xpi/}
+DIST_SUBDIR= xpi/${DISTNAME}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Localized interface for Firefox
+
+.ifndef WITHOUT_SWITCHER
+RUN_DEPENDS+= xpi-locale-switcher>=0:${PORTSDIR}/www/xpi-locale-switcher
+.endif
+
+NO_BUILD= yes
+USE_XPI= *firefox
+
+FIREFOX_I18N_ALL= ar bg ca cs da de el en-GB es-AR es-ES eu fi fr ga-IE gu-IN he hu it \
+ ja ko mk nb-NO nl pa-IN pl pt-BR ro ru sk sl sv-SE tr zh-CN zh-TW
+FIREFOX_I18N?= zh-CN de fr ja ru it es-ES
+
+.if ${FIREFOX_I18N} == all
+FIREFOX_I18N= ${FIREFOX_I18N_ALL}
+.endif
+
+WDIR= langpack-*@firefox.mozilla.org
+
+XPI_DISTNAMES= ${FIREFOX_I18N}
+.for dist in ${XPI_DISTNAMES}
+XPI_ID_${dist}= langpack-${dist}@firefox.mozilla.org
+XPI_FILES_${dist}= chrome.manifest install.rdf chrome/${dist}.jar chrome/chromelist.txt
+XPI_DIRS_${dist}= chrome
+.endfor
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR} ${WRKSRC}
+ @for lang in ${FIREFOX_I18N}; do \
+ if ! (${EXTRACT_CMD} ${_DISTDIR}/$$lang.xpi -d ${WRKSRC}/langpack-$$lang@firefox.mozilla.org);\
+ then \
+ exit 1; \
+ fi \
+ done
+
+do-install:
+ @${INSTALL} -d ${XPI_LIBDIR}
+ @${CP} -Rp ${WRKSRC}/ ${XPI_LIBDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${XPI_LIBDIR}/${WDIR}/
+ @${CHMOD} -R a+rX,go-w ${XPI_LIBDIR}/${WDIR}/
+ @for _app in ${XPI_APPS} ; { for _xpi in ${XPI_LIBDIR}/${WDIR} ; { \
+ ${LN} -sf $$_xpi $$_app ${_Q} ; } ; }
+ @${ECHO_CMD} '@exec for _app in ${XPI_APPS} ; { for _xpi in ${XPI_LIBDIR}/${WDIR} ; { \
+ ${LN} -sf $$_xpi $$_app ${_Q} ; } ; }' ${_A}
+ @${ECHO_CMD} '@unexec for _app in ${XPI_APPS} ; { ${RM} -f $$_app/${WDIR} ; }' ${_A}
+ @${ECHO_CMD} '@unexec rmdir ${XPI_LIBDIR:S,^${PREFIX},%D,} ${_Q}' ${_A}
+
+post-patch:
+ ${FIND} ${WRKSRC} -name install.rdf -print0 | \
+ ${XARGS} -0L1 ${REINPLACE_CMD} -i '' '/<?xml/,$$!d'
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>