aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-11 08:53:59 +0800
committerjbeich <jbeich@FreeBSD.org>2018-01-11 08:53:59 +0800
commitd6a5bdb365b6018c05ab93622365fe417261fe43 (patch)
tree92094d37e2e55531681c18c7923698daac99d3f4 /www/firefox
parent7d9b5034edf85108ad31c79f29f050594bade6a8 (diff)
downloadfreebsd-ports-gnome-d6a5bdb365b6018c05ab93622365fe417261fe43.tar.gz
freebsd-ports-gnome-d6a5bdb365b6018c05ab93622365fe417261fe43.tar.zst
freebsd-ports-gnome-d6a5bdb365b6018c05ab93622365fe417261fe43.zip
www/firefox: work around crash on FreeBSD 10
PR: 224917 Suggested by: dim
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-ipc_glue_MessageChannel.cpp14
2 files changed, 15 insertions, 0 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 1472b08a990c..0d88ed02413c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 57.0.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-ipc_glue_MessageChannel.cpp b/www/firefox/files/patch-ipc_glue_MessageChannel.cpp
new file mode 100644
index 000000000000..2b3e860fda18
--- /dev/null
+++ b/www/firefox/files/patch-ipc_glue_MessageChannel.cpp
@@ -0,0 +1,14 @@
+--- ipc/glue/MessageChannel.cpp.orig 2017-11-02 16:16:32 UTC
++++ ipc/glue/MessageChannel.cpp
+@@ -685,6 +685,11 @@ MessageChannel::WillDestroyCurrentMessageLoop()
+ mWorkerLoop = nullptr;
+ }
+
++#if defined(_LIBCPP_VERSION) && _LIBCPP_VERSION < 4000
++// Work around UB in __tree crashing mPendingPromises.clear()
++// http://llvm.org/viewvc/llvm-project?view=revision&revision=276003
++[[clang::optnone]]
++#endif
+ void
+ MessageChannel::Clear()
+ {