aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-03-09 02:10:48 +0800
committerjbeich <jbeich@FreeBSD.org>2015-03-09 02:10:48 +0800
commit06c49c503afc94f6f42a423bc27e153cfb951447 (patch)
treee881bb2f9265834eee124e71f494c002853470bf /www/firefox
parent0a3751e4dec99db37c42fc70143abd86bbb215a9 (diff)
downloadfreebsd-ports-gnome-06c49c503afc94f6f42a423bc27e153cfb951447.tar.gz
freebsd-ports-gnome-06c49c503afc94f6f42a423bc27e153cfb951447.tar.zst
freebsd-ports-gnome-06c49c503afc94f6f42a423bc27e153cfb951447.zip
- Add CANBERRA and enable by default for Thunderbird and SeaMonkey [1]
- Bump version requirements for harfbuzz and libvorbis PR: 198142 [1] See also: https://dxr.mozilla.org/comm-central/search?q=nsISound [1]
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile4
-rw-r--r--www/firefox/Makefile.options6
-rw-r--r--www/firefox/files/patch-bug8475682
-rw-r--r--www/firefox/files/patch-z-bug5174222
4 files changed, 8 insertions, 6 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index c97a0a517cf6..0bf68b576de4 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -17,9 +17,9 @@ BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
libevent2>=2.0.21_2:${PORTSDIR}/devel/libevent2 \
cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo \
soundtouch>=1.8.0:${PORTSDIR}/audio/soundtouch \
- harfbuzz>=0.9.25:${PORTSDIR}/print/harfbuzz \
+ harfbuzz>=0.9.34:${PORTSDIR}/print/harfbuzz \
graphite2>=1.2.4:${PORTSDIR}/graphics/graphite2 \
- libvorbis>=1.3.4:${PORTSDIR}/audio/libvorbis \
+ libvorbis>=1.3.5:${PORTSDIR}/audio/libvorbis \
opus>=1.1:${PORTSDIR}/audio/opus \
libvpx>=1.3.0:${PORTSDIR}/multimedia/libvpx \
sqlite3>=3.8.7.4:${PORTSDIR}/databases/sqlite3 \
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index a0c4b7ca95d1..969d49dd4db8 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -1,12 +1,14 @@
# -*- makefile-bsdmake -*-
-OPTIONS_DEFINE+= DBUS DEBUG DTRACE GCONF GIO GNOMEUI GSTREAMER \
- LIBPROXY LOGGING OPTIMIZED_CFLAGS PGO PROFILE TEST
+OPTIONS_DEFINE+= CANBERRA DBUS DEBUG DTRACE GCONF GIO GNOMEUI \
+ GSTREAMER LIBPROXY LOGGING OPTIMIZED_CFLAGS \
+ PGO PROFILE TEST
OPTIONS_DEFAULT+= ALSA DBUS GIO GSTREAMER LOGGING OPTIMIZED_CFLAGS
OPTIONS_MULTI+= AUDIO
OPTIONS_MULTI_AUDIO= ALSA PULSEAUDIO
+CANBERRA_DESC?= Sound theme alerts
ENIGMAIL_DESC?= Enigmail extension
GNOMEUI_DESC?= libgnomeui support module
LIBPROXY_DESC?= Proxy support via libproxy
diff --git a/www/firefox/files/patch-bug847568 b/www/firefox/files/patch-bug847568
index 2ffb2dbfb5e8..bc53bcd16c8d 100644
--- a/www/firefox/files/patch-bug847568
+++ b/www/firefox/files/patch-bug847568
@@ -46,7 +46,7 @@ index ac38f40..87536b7 100644
+MOZ_NATIVE_HARFBUZZ=)
+
+if test -n "$MOZ_NATIVE_HARFBUZZ"; then
-+ PKG_CHECK_MODULES(MOZ_HARFBUZZ, harfbuzz >= 0.9.25)
++ PKG_CHECK_MODULES(MOZ_HARFBUZZ, harfbuzz >= 0.9.34)
+fi
+
+AC_SUBST(MOZ_NATIVE_HARFBUZZ)
diff --git a/www/firefox/files/patch-z-bug517422 b/www/firefox/files/patch-z-bug517422
index 13432e8deb4f..f837f2db6735 100644
--- a/www/firefox/files/patch-z-bug517422
+++ b/www/firefox/files/patch-z-bug517422
@@ -154,7 +154,7 @@ index 87db361..7947626 100644
+MOZ_NATIVE_VORBIS=)
+
+if test -n "$MOZ_NATIVE_VORBIS"; then
-+ PKG_CHECK_MODULES(MOZ_VORBIS, vorbis vorbisenc >= 1.3.4)
++ PKG_CHECK_MODULES(MOZ_VORBIS, vorbis vorbisenc >= 1.3.5)
+fi
+
+AC_SUBST(MOZ_NATIVE_VORBIS)