aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-09-07 02:34:37 +0800
committermarcus <marcus@FreeBSD.org>2003-09-07 02:34:37 +0800
commitaaef62a5e5286777b173c3c108ac606ca40f0a6e (patch)
treec4aef6f28e10b7a04f71b27aab8c73550afa1f8e /www/firefox
parentae8d70049f4eda926ea5072a555ab996684c111c (diff)
downloadfreebsd-ports-gnome-aaef62a5e5286777b173c3c108ac606ca40f0a6e.tar.gz
freebsd-ports-gnome-aaef62a5e5286777b173c3c108ac606ca40f0a6e.tar.zst
freebsd-ports-gnome-aaef62a5e5286777b173c3c108ac606ca40f0a6e.zip
Use ${PTHREAD_LIBS} instead of hardcoded -pthread and -lc_r in a few places.
This should help the KSE and libthr people use these applications (plus it lets them build on -CURRENT).
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index cc6b355f762d..0eea15c6840b 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -111,6 +111,13 @@ post-extract::
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/build/unix/run-mozilla.sh
+ @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/nsprpub/config/FreeBSD.mk \
+ ${WRKSRC}/security/coreconf/FreeBSD.mk \
+ ${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
+ ${WRKSRC}/js/src/Makefile.in
pre-install:
${RM} -fr ${LOCAL_PREFIX}