aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2011-10-20 03:29:28 +0800
committerbeat <beat@FreeBSD.org>2011-10-20 03:29:28 +0800
commitbd6e1a93210834eae68ceab5f49f2de7e97b2f82 (patch)
tree39f3a2a9be2ff2ff39ff25a54dffa4df180d0ddc /www/firefox
parent2f32fd423868295cee22c40c54a89d8df8644ac2 (diff)
downloadfreebsd-ports-gnome-bd6e1a93210834eae68ceab5f49f2de7e97b2f82.tar.gz
freebsd-ports-gnome-bd6e1a93210834eae68ceab5f49f2de7e97b2f82.tar.zst
freebsd-ports-gnome-bd6e1a93210834eae68ceab5f49f2de7e97b2f82.zip
- Add x-scheme-handler/http(s) MimeTypes to firefox.desktop. [1]
- Add temporary workaround to fix detection of all plugins until we have found a proper solution for this problem. The workaround use the run-mozilla.sh script to start Firefox as it was the default prior to the Firefox 7 release. [2] - Bump PORTREVISION. PR: ports/159606 [1] Submitted by: Dmitry <smallcms AT gmail.com> [1] Discussed with: flo@ [2]
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile8
-rw-r--r--www/firefox/files/firefox.desktop.in2
2 files changed, 9 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 32f3f1b13fb5..d023d2ed5f17 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
DISTVERSION= 7.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -136,6 +137,13 @@ post-configure:
(cd ${WRKSRC} && ${GMAKE} distclean)
.endif
+post-build:
+ ${RM} ${WRKSRC}/dist/bin/${PORTNAME}
+ ${ECHO_CMD} "#!/bin/sh" > ${WRKSRC}/dist/bin/${PORTNAME}
+ ${ECHO_CMD} "cd ${PREFIX}/lib/firefox && ./run-mozilla.sh ./firefox-bin" \
+ >> ${WRKSRC}/dist/bin/${PORTNAME}
+ ${CHMOD} 755 ${WRKSRC}/dist/bin/${PORTNAME}
+
port-pre-install:
${ECHO_CMD} 'share/applications/${MOZILLA}.desktop' >> ${PLISTF}
${ECHO_CMD} "@dirrmtry share/applications" >> ${PLISTD}
diff --git a/www/firefox/files/firefox.desktop.in b/www/firefox/files/firefox.desktop.in
index d72090e1aabf..27b81ce2bdd7 100644
--- a/www/firefox/files/firefox.desktop.in
+++ b/www/firefox/files/firefox.desktop.in
@@ -188,4 +188,4 @@ StartupNotify=false
Terminal=false
Type=Application
Categories=Application;Network;
-MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;