aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-18 01:43:21 +0800
committerflo <flo@FreeBSD.org>2013-05-18 01:43:21 +0800
commit51ef5c0827fe4de7f257fae988e2e266e41efbd1 (patch)
tree4a67ac28b3a263220c3cdd63a6f98779269ce95c /www/firefox
parentf5701852a3190ec1f79d9dfdce407bc04acab439 (diff)
downloadfreebsd-ports-gnome-51ef5c0827fe4de7f257fae988e2e266e41efbd1.tar.gz
freebsd-ports-gnome-51ef5c0827fe4de7f257fae988e2e266e41efbd1.tar.zst
freebsd-ports-gnome-51ef5c0827fe4de7f257fae988e2e266e41efbd1.zip
Fix icon installation
PR: ports/178711 PR: ports/178721 Submitted by: Denny Lin <dennylin93@hs.ntnu.edu.tw> > Description of fields to fill in above: 76 columns --| > PR: If a GNATS PR is affected by the change. > Submitted by: If someone else sent in the change. > Reviewed by: If someone else reviewed your modification. > Approved by: If you needed approval for this commit. > Obtained from: If the change is from a third party. > MFC after: N [day[s]|week[s]|month[s]]. Request a reminder email. > Security: Vulnerability reference (one per line) or description. > Sponsored by: If the change was sponsored by an organization. > Empty fields above will be automatically removed. M firefox/Makefile
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index fb35654fb824..127dfa913e8d 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 21.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source
@@ -40,7 +41,7 @@ USE_DOS2UNIX= media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spr
NO_MOZPKGINSTALL=yes
FIREFOX_ICON= ${MOZILLA}.png
-FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/chrome/icons/default/default48.png
+FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
--enable-application=browser \
--enable-official-branding
@@ -100,14 +101,10 @@ port-pre-install:
${ECHO_CMD} 'share/applications/${MOZILLA}.desktop' >> ${PLISTF}
${ECHO_CMD} "@dirrmtry share/applications" >> ${PLISTD}
${ECHO_CMD} 'share/pixmaps/${FIREFOX_ICON}' >> ${PLISTF}
- ${ECHO_CMD} "@dirrm lib/firefox/chrome/icons/default" >> ${PLISTD}
- ${ECHO_CMD} "@dirrm lib/firefox/chrome/icons" >> ${PLISTD}
- ${ECHO_CMD} "@dirrm lib/firefox/chrome" >> ${PLISTD}
post-install:
${MKDIR} ${PREFIX}/share/applications ${PREFIX}/share/pixmaps
${INSTALL_DATA} ${WRKDIR}/${MOZILLA}.desktop ${PREFIX}/share/applications/
- ${MKDIR} ${PREFIX}/lib/${MOZILLA}/chrome/icons/default
${LN} -sf ${FIREFOX_ICON_SRC} ${PREFIX}/share/pixmaps/${FIREFOX_ICON}
@${CAT} ${PKGMESSAGE}