aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-08-10 00:30:43 +0800
committerjbeich <jbeich@FreeBSD.org>2015-08-10 00:30:43 +0800
commite378c86e4dbb9cc9af1abfffa3d938bf671f6ce3 (patch)
tree6f5c1fdabd9e133349117d559ffcd98bd049802d /www/firefox
parent0c68736bfae752bef76b8bad4961331960c12ec4 (diff)
downloadfreebsd-ports-gnome-e378c86e4dbb9cc9af1abfffa3d938bf671f6ce3.tar.gz
freebsd-ports-gnome-e378c86e4dbb9cc9af1abfffa3d938bf671f6ce3.tar.zst
freebsd-ports-gnome-e378c86e4dbb9cc9af1abfffa3d938bf671f6ce3.zip
www/firefox: make testing bundled cairo easier via option
BUNDLED_CAIRO does nothing with GTK3 until Firefox 41.0 https://bugzilla.mozilla.org/show_bug.cgi?id=1159273 PR: 202174 MFH: 2015Q3
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile5
-rw-r--r--www/firefox/Makefile.options6
2 files changed, 8 insertions, 3 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 5af00793fd39..b8b0aa7345cf 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -15,7 +15,6 @@ COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.10.8:${PORTSDIR}/devel/nspr \
nss>=3.19.2:${PORTSDIR}/security/nss \
libevent2>=2.0.21_2:${PORTSDIR}/devel/libevent2 \
- cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo \
soundtouch>=1.8.0:${PORTSDIR}/audio/soundtouch \
harfbuzz>=0.9.34:${PORTSDIR}/print/harfbuzz \
graphite2>=1.2.4:${PORTSDIR}/graphics/graphite2 \
@@ -64,6 +63,10 @@ WRKSRC:= ${WRKDIR}/mozilla-release
RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
.endif
+.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
+BUILD_DEPENDS+= cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo
+.endif
+
.if ${PORT_OPTIONS:MGSTREAMER}
RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
.endif
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index 969d49dd4db8..1f8f8453cef9 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -1,13 +1,15 @@
# -*- makefile-bsdmake -*-
-OPTIONS_DEFINE+= CANBERRA DBUS DEBUG DTRACE GCONF GIO GNOMEUI \
- GSTREAMER LIBPROXY LOGGING OPTIMIZED_CFLAGS \
+OPTIONS_DEFINE+= BUNDLED_CAIRO CANBERRA DBUS DEBUG DTRACE GCONF GIO \
+ GNOMEUI GSTREAMER LIBPROXY LOGGING OPTIMIZED_CFLAGS \
PGO PROFILE TEST
+
OPTIONS_DEFAULT+= ALSA DBUS GIO GSTREAMER LOGGING OPTIMIZED_CFLAGS
OPTIONS_MULTI+= AUDIO
OPTIONS_MULTI_AUDIO= ALSA PULSEAUDIO
+BUNDLED_CAIRO_DESC?= Use bundled fork of cairo-1.9.5
CANBERRA_DESC?= Sound theme alerts
ENIGMAIL_DESC?= Enigmail extension
GNOMEUI_DESC?= libgnomeui support module