aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-12-16 17:37:45 +0800
committerjbeich <jbeich@FreeBSD.org>2015-12-16 17:37:45 +0800
commita2b1a5a4be9bd3306e1fb0f1076b057e5905cc8a (patch)
tree01d43647787c90ec24d8ded6c52221b97251323d /www/firefox
parent56d4f18b1b915a3c405817f36f1fec2bd26af87f (diff)
downloadfreebsd-ports-gnome-a2b1a5a4be9bd3306e1fb0f1076b057e5905cc8a.tar.gz
freebsd-ports-gnome-a2b1a5a4be9bd3306e1fb0f1076b057e5905cc8a.tar.zst
freebsd-ports-gnome-a2b1a5a4be9bd3306e1fb0f1076b057e5905cc8a.zip
gecko: drop FreeBSD 8.x and 9.0 support
DragonFly has a similar getchar() workaround in DPorts, so this would be a bit bumpy due to USES=dos2unix removal causing a patchconflict. However, OS X (since 10.3) and other BSDs (except OpenBSD) fixed stdio.h instead. https://github.com/android/platform_bionic/commit/f2cea021ab2c6d7d7feeb40cca098aa132605876 https://github.com/bitrig/bitrig/commit/1abd6adb31462edf8f2875e3d03ba8cd2af713df https://github.com/jsonn/src/commit/d782c95120fdb70f3b8d74e5a183bfb0f98fc770 https://github.com/freebsd/freebsd/commit/dd1ce6fd6c2c0f0c70f3c78a4959185bb93eb1c3 https://github.com/unofficial-opensource-apple/Libc/tree/569b0a5190c89f8729c22e09fb15f6252feadcfc/include/stdio.h
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile3
-rw-r--r--www/firefox/files/patch-media-libstagefright-foundation-AString.cpp16
-rw-r--r--www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp16
3 files changed, 1 insertions, 34 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index a023757262f5..239caf8db980 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -40,8 +40,7 @@ MOZILLA_NAME= Firefox
USE_QT5= # empty
QT_NONSTANDARD= yes
USE_GL= gl
-USES= dos2unix tar:xz
-DOS2UNIX_FILES= media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
+USES= tar:xz
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
diff --git a/www/firefox/files/patch-media-libstagefright-foundation-AString.cpp b/www/firefox/files/patch-media-libstagefright-foundation-AString.cpp
deleted file mode 100644
index 530902b13393..000000000000
--- a/www/firefox/files/patch-media-libstagefright-foundation-AString.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp~
-+++ media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp
-@@ -23,6 +23,13 @@
- #include "ADebug.h"
- #include "AString.h"
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# undef tolower
-+# endif
-+#endif
-+
- namespace stagefright {
-
- // static
diff --git a/www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp b/www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
deleted file mode 100644
index eeb58e7baa20..000000000000
--- a/www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp~
-+++ media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
-@@ -21,6 +21,13 @@ Scott McMurray
- #include "constants.hpp"
- #include <cstring>
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# define getchar boost_getchar
-+# endif
-+#endif
-+
- namespace boost {
- namespace detail {
- //This only works on unsigned data types