aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2014-09-25 19:08:06 +0800
committerbeat <beat@FreeBSD.org>2014-09-25 19:08:06 +0800
commit7af9096bbe75ee527c3a3be7eb11df8ba35917ee (patch)
tree15beb33a726d7771344d21f67a35c20db06c34a3 /www/firefox
parent8858214fcbe80e7199b996909d65e93b7b8fb92c (diff)
downloadfreebsd-ports-gnome-7af9096bbe75ee527c3a3be7eb11df8ba35917ee.tar.gz
freebsd-ports-gnome-7af9096bbe75ee527c3a3be7eb11df8ba35917ee.tar.zst
freebsd-ports-gnome-7af9096bbe75ee527c3a3be7eb11df8ba35917ee.zip
- Update ca_root_nss to 3.17.1
- Update thunderbird to 31.1.2 - Update seamonkey to 2.29.1 - Update firefox to 32.0.3 - Update firefox-esr to 31.1.1 - Update libxul to 24.8.1 Submitted by: Jan Beich Security: http://www.vuxml.org/freebsd/48108fb0-751c-4cbb-8f33-09239ead4b55.html
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile8
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/patch-bug104126826
3 files changed, 6 insertions, 32 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 47d8e7ffcb01..96bfee96fbe9 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 32.0
+DISTVERSION= 32.0.3
DISTVERSIONSUFFIX=.source
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
@@ -15,6 +14,8 @@ COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
nss>=3.16.2:${PORTSDIR}/security/nss \
+ libevent2>=2.0.21_2:${PORTSDIR}/devel/libevent2 \
+ cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo \
soundtouch>=1.8.0:${PORTSDIR}/audio/soundtouch \
harfbuzz>=0.9.25:${PORTSDIR}/print/harfbuzz \
graphite2>=1.2.4:${PORTSDIR}/graphics/graphite2 \
@@ -26,7 +27,6 @@ BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
-# cairo>=1.12.16,2:${PORTSDIR}/graphics/cairo \
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
@@ -35,7 +35,7 @@ OBJDIR_BUILD= # in-tree build broken after bug 789837
USE_GECKO= gecko
CONFLICTS= firefox-esr-31.* firefox-esr-24.* firefox-esr-17.*
MOZ_PKGCONFIG_FILES= # empty
-USE_MOZILLA= -cairo
+USE_MOZILLA= # empty
MOZILLA_NAME= Firefox
WANT_GNOME= yes
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 652cb6ea4468..add936a9fe79 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-32.0.source.tar.bz2) = 3265971e15809ab904403b474fa9eccf15f34697deb16fc400c5c3684afd50eb
-SIZE (firefox-32.0.source.tar.bz2) = 149914070
+SHA256 (firefox-32.0.3.source.tar.bz2) = ae2aa20538d03b392a04663593fb106c0aec2d8bbb78ddac84a88ce7617b1efe
+SIZE (firefox-32.0.3.source.tar.bz2) = 150323569
diff --git a/www/firefox/files/patch-bug1041268 b/www/firefox/files/patch-bug1041268
deleted file mode 100644
index d4ab1a91395e..000000000000
--- a/www/firefox/files/patch-bug1041268
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.cc media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.cc
-index 97f69d3..77a50b3 100644
---- media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.cc
-+++ media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.cc
-@@ -18,7 +18,7 @@ ScreenCapturer* ScreenCapturer::Create() {
- return Create(DesktopCaptureOptions::CreateDefault());
- }
-
--#if defined(WEBRTC_LINUX)
-+#if defined(WEBRTC_LINUX) || defined(WEBRTC_BSD)
- ScreenCapturer* ScreenCapturer::CreateWithXDamage(
- bool use_update_notifications) {
- DesktopCaptureOptions options;
-diff --git media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.h media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.h
-index a8d40a7..177a6c1 100644
---- media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.h
-+++ media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer.h
-@@ -74,7 +74,7 @@ class ScreenCapturer : public DesktopCapturer {
- static ScreenCapturer* Create(const DesktopCaptureOptions& options);
- static ScreenCapturer* Create();
-
--#if defined(WEBRTC_LINUX)
-+#if defined(WEBRTC_LINUX) || defined(WEBRTC_BSD)
- // Creates platform-specific capturer and instructs it whether it should use
- // X DAMAGE support.
- static ScreenCapturer* CreateWithXDamage(bool use_x_damage);