aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2007-11-29 09:37:39 +0800
committerdelphij <delphij@FreeBSD.org>2007-11-29 09:37:39 +0800
commitbc12c962fd4f80c4806b182b48233ea8fd9b3852 (patch)
tree0c020988d3c22b934ef68d825929b9f46adc5109 /www/firefox
parent7b4308f718943c46452e830597bab217992b79f6 (diff)
downloadfreebsd-ports-gnome-bc12c962fd4f80c4806b182b48233ea8fd9b3852.tar.gz
freebsd-ports-gnome-bc12c962fd4f80c4806b182b48233ea8fd9b3852.tar.zst
freebsd-ports-gnome-bc12c962fd4f80c4806b182b48233ea8fd9b3852.zip
Fix a regression on firefox 2.0.0.10, as described in Mozilla bug 405584,
affecting canvas rendering. Obtained from: https://bugzilla.mozilla.org/attachment.cgi?id=284556 Approved by: portmgr (marcus)
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp26
2 files changed, 27 insertions, 0 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index aac7df1ee3fc..bfa0a1396acb 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -8,6 +8,7 @@
PORTNAME= firefox
DISTVERSION= 2.0.0.10
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
diff --git a/www/firefox/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp b/www/firefox/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp
new file mode 100644
index 000000000000..cf50f57e3288
--- /dev/null
+++ b/www/firefox/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp
@@ -0,0 +1,26 @@
+Index: content/canvas/src/nsCanvasRenderingContext2D.cpp
+===================================================================
+RCS file: /cvsroot/mozilla/content/canvas/src/nsCanvasRenderingContext2D.cpp,v
+retrieving revision 1.102
+diff -u -8 -p -r1.102 nsCanvasRenderingContext2D.cpp
+--- content/canvas/src/nsCanvasRenderingContext2D.cpp 10 Oct 2007 20:31:45 -0000 1.102
++++ content/canvas/src/nsCanvasRenderingContext2D.cpp 11 Oct 2007 23:31:32 -0000
+@@ -2140,17 +2140,17 @@ nsCanvasRenderingContext2D::CairoSurface
+ getter_AddRefs(imgRequest));
+ NS_ENSURE_SUCCESS(rv, rv);
+ if (!imgRequest)
+ // XXX ERRMSG we need to report an error to developers here! (bug 329026)
+ return NS_ERROR_NOT_AVAILABLE;
+
+ PRUint32 status;
+ imgRequest->GetImageStatus(&status);
+- if (status != imgIRequest::STATUS_LOAD_COMPLETE)
++ if ((status & imgIRequest::STATUS_LOAD_COMPLETE) == 0)
+ return NS_ERROR_NOT_AVAILABLE;
+
+ nsCOMPtr<nsIURI> uri;
+ rv = imageLoader->GetCurrentURI(uriOut);
+ NS_ENSURE_SUCCESS(rv, rv);
+
+ *forceWriteOnlyOut = PR_FALSE;
+