aboutsummaryrefslogtreecommitdiffstats
path: root/www/fluxbb
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2015-06-05 11:02:45 +0800
committerwen <wen@FreeBSD.org>2015-06-05 11:02:45 +0800
commit66295be37943c8671f6cd021b2ff1d15198c746b (patch)
tree1b117cd1b56430bd4356d300f389409c908c30cd /www/fluxbb
parentd9088ab2080636e634d209fa8baa1344ebe4471b (diff)
downloadfreebsd-ports-gnome-66295be37943c8671f6cd021b2ff1d15198c746b.tar.gz
freebsd-ports-gnome-66295be37943c8671f6cd021b2ff1d15198c746b.tar.zst
freebsd-ports-gnome-66295be37943c8671f6cd021b2ff1d15198c746b.zip
- Update to 1.5.8
- Add LICENSE [1] - Add CPE [1] - Use OPTIONS helpers [1] - Fix tab after WWW: [1] - Fix file permissions - Update pkg-descr PR: 200574 [1] Submitted by: amdmi3@ [1]
Diffstat (limited to 'www/fluxbb')
-rw-r--r--www/fluxbb/Makefile29
-rw-r--r--www/fluxbb/distinfo4
-rw-r--r--www/fluxbb/files/pkg-message.in16
-rw-r--r--www/fluxbb/pkg-descr2
-rw-r--r--www/fluxbb/pkg-plist65
5 files changed, 47 insertions, 69 deletions
diff --git a/www/fluxbb/Makefile b/www/fluxbb/Makefile
index 546deb101eb3..3255902cfb3a 100644
--- a/www/fluxbb/Makefile
+++ b/www/fluxbb/Makefile
@@ -2,42 +2,29 @@
# $FreeBSD$
PORTNAME= fluxbb
-PORTVERSION= 1.4.4
+PORTVERSION= 1.5.8
CATEGORIES= www
MASTER_SITES= http://fluxbb.org/download/releases/${PORTVERSION}/
MAINTAINER= wen@FreeBSD.org
COMMENT= Fast and lightweight PHP-powered discussion board
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cpe
SUB_FILES= pkg-message
NO_BUILD= yes
USE_PHP= yes
OPTIONS_DEFINE= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= MYSQL
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite
-.endif
-
-do-extract:
- @${MKDIR} ${WRKSRC}
- @${TAR} -yxf ${DISTDIR}/${DISTFILES} -C ${WRKSRC}
+MYSQL_USE= PHP=mysql
+PGSQL_USE= PHP=pgsql
+SQLITE_USE= PHP=sqlite
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}' >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/www/fluxbb/distinfo b/www/fluxbb/distinfo
index 8f81337d66ee..b13ac29e0b8b 100644
--- a/www/fluxbb/distinfo
+++ b/www/fluxbb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fluxbb-1.4.4.tar.gz) = a69253c1eef173d9888bbfa34dd7f413ab6443944d4209699f9bf1dc610639c5
-SIZE (fluxbb-1.4.4.tar.gz) = 276720
+SHA256 (fluxbb-1.5.8.tar.gz) = e631300a5d6f9107d2c9a80af796f1ceceb18dc3bd0be65326a721b395069eed
+SIZE (fluxbb-1.5.8.tar.gz) = 286801
diff --git a/www/fluxbb/files/pkg-message.in b/www/fluxbb/files/pkg-message.in
index 1130c3fe0f04..905f78709508 100644
--- a/www/fluxbb/files/pkg-message.in
+++ b/www/fluxbb/files/pkg-message.in
@@ -5,10 +5,11 @@ To complete the installation , please:
1) Create a user and a database for FluxBB to store all
its tables in (or choose an existing database).
-2) Add the following to your Apache configuration, and
- restart the server:
+2) Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ For Apache versions earlier than 2.4:
- ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
Alias /fluxbb %%WWWDIR%%/
AcceptPathInfo On
<Directory %%WWWDIR%%>
@@ -17,6 +18,15 @@ To complete the installation , please:
Allow from all
</Directory>
+ For Apache version 2.4.x or above:
+
+ Alias /fluxbb %%WWWDIR%%/
+ AcceptPathInfo On
+ <Directory %%WWWDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
3) Visit your FluxBB site with a browser (i.e.,
http://your.server.com/fluxbb/), and you should
be taken to the install.php script, which will lead
diff --git a/www/fluxbb/pkg-descr b/www/fluxbb/pkg-descr
index fce975afd52b..5eccec0751eb 100644
--- a/www/fluxbb/pkg-descr
+++ b/www/fluxbb/pkg-descr
@@ -5,4 +5,4 @@ light with less of the "not so essential" features that some of
the other forums have whilst not sacrificing essential functionality
or usability.
-WWW: http://www.fluxbb.org/
+WWW: http://www.fluxbb.org/
diff --git a/www/fluxbb/pkg-plist b/www/fluxbb/pkg-plist
index 0bf5ead6e43a..7993ef444545 100644
--- a/www/fluxbb/pkg-plist
+++ b/www/fluxbb/pkg-plist
@@ -1,5 +1,5 @@
%%WWWDIR%%/COPYING
-%%WWWDIR%%/README
+%%WWWDIR%%/addons/index.html
%%WWWDIR%%/admin_bans.php
%%WWWDIR%%/admin_categories.php
%%WWWDIR%%/admin_censoring.php
@@ -10,12 +10,12 @@
%%WWWDIR%%/admin_maintenance.php
%%WWWDIR%%/admin_options.php
%%WWWDIR%%/admin_permissions.php
-%%WWWDIR%%/admin_prune.php
-%%WWWDIR%%/admin_ranks.php
%%WWWDIR%%/admin_reports.php
+%%WWWDIR%%/admin_statistics.php
%%WWWDIR%%/admin_users.php
%%WWWDIR%%/cache/.htaccess
%%WWWDIR%%/cache/index.html
+%%WWWDIR%%/common.js
%%WWWDIR%%/db_update.php
%%WWWDIR%%/delete.php
%%WWWDIR%%/edit.php
@@ -39,6 +39,7 @@
%%WWWDIR%%/img/smilies/wink.png
%%WWWDIR%%/img/smilies/yikes.png
%%WWWDIR%%/img/test.png
+%%WWWDIR%%/include/addons.php
%%WWWDIR%%/include/cache.php
%%WWWDIR%%/include/common.php
%%WWWDIR%%/include/common_admin.php
@@ -55,12 +56,14 @@
%%WWWDIR%%/include/index.html
%%WWWDIR%%/include/parser.php
%%WWWDIR%%/include/search_idx.php
+%%WWWDIR%%/include/srand.php
%%WWWDIR%%/include/template/admin.tpl
%%WWWDIR%%/include/template/help.tpl
%%WWWDIR%%/include/template/index.html
%%WWWDIR%%/include/template/main.tpl
%%WWWDIR%%/include/template/maintenance.tpl
%%WWWDIR%%/include/template/redirect.tpl
+%%WWWDIR%%/include/user/index.html
%%WWWDIR%%/include/utf8/index.html
%%WWWDIR%%/include/utf8/mbstring/core.php
%%WWWDIR%%/include/utf8/mbstring/index.html
@@ -100,8 +103,6 @@
%%WWWDIR%%/lang/English/admin_maintenance.php
%%WWWDIR%%/lang/English/admin_options.php
%%WWWDIR%%/lang/English/admin_permissions.php
-%%WWWDIR%%/lang/English/admin_prune.php
-%%WWWDIR%%/lang/English/admin_ranks.php
%%WWWDIR%%/lang/English/admin_reports.php
%%WWWDIR%%/lang/English/admin_users.php
%%WWWDIR%%/lang/English/common.php
@@ -114,12 +115,19 @@
%%WWWDIR%%/lang/English/login.php
%%WWWDIR%%/lang/English/mail_templates/activate_email.tpl
%%WWWDIR%%/lang/English/mail_templates/activate_password.tpl
+%%WWWDIR%%/lang/English/mail_templates/banned_email_change.tpl
+%%WWWDIR%%/lang/English/mail_templates/banned_email_post.tpl
+%%WWWDIR%%/lang/English/mail_templates/banned_email_register.tpl
+%%WWWDIR%%/lang/English/mail_templates/dupe_email_change.tpl
+%%WWWDIR%%/lang/English/mail_templates/dupe_email_register.tpl
%%WWWDIR%%/lang/English/mail_templates/form_email.tpl
%%WWWDIR%%/lang/English/mail_templates/index.html
%%WWWDIR%%/lang/English/mail_templates/new_reply.tpl
%%WWWDIR%%/lang/English/mail_templates/new_reply_full.tpl
+%%WWWDIR%%/lang/English/mail_templates/new_report.tpl
%%WWWDIR%%/lang/English/mail_templates/new_topic.tpl
%%WWWDIR%%/lang/English/mail_templates/new_topic_full.tpl
+%%WWWDIR%%/lang/English/mail_templates/new_user.tpl
%%WWWDIR%%/lang/English/mail_templates/rename.tpl
%%WWWDIR%%/lang/English/mail_templates/welcome.tpl
%%WWWDIR%%/lang/English/misc.php
@@ -130,8 +138,8 @@
%%WWWDIR%%/lang/English/search.php
%%WWWDIR%%/lang/English/stopwords.txt
%%WWWDIR%%/lang/English/topic.php
-%%WWWDIR%%/lang/English/userlist.php
%%WWWDIR%%/lang/English/update.php
+%%WWWDIR%%/lang/English/userlist.php
%%WWWDIR%%/lang/index.html
%%WWWDIR%%/login.php
%%WWWDIR%%/misc.php
@@ -139,8 +147,10 @@
%%WWWDIR%%/plugins/index.html
%%WWWDIR%%/post.php
%%WWWDIR%%/profile.php
+%%WWWDIR%%/readme.md
%%WWWDIR%%/register.php
%%WWWDIR%%/search.php
+%%WWWDIR%%/style/Air.css
%%WWWDIR%%/style/Air/base_admin.css
%%WWWDIR%%/style/Air/img/asterisk.png
%%WWWDIR%%/style/Air/img/bull.png
@@ -150,11 +160,9 @@
%%WWWDIR%%/style/Air/img/feed.png
%%WWWDIR%%/style/Air/img/help.png
%%WWWDIR%%/style/Air/img/index.html
-%%WWWDIR%%/style/Air/img/main_end.png
-%%WWWDIR%%/style/Air/img/main_top.png
%%WWWDIR%%/style/Air/index.html
-%%WWWDIR%%/style/Air.css
%%WWWDIR%%/style/Cobalt.css
+%%WWWDIR%%/style/Earth.css
%%WWWDIR%%/style/Earth/base_admin.css
%%WWWDIR%%/style/Earth/img/asterisk.png
%%WWWDIR%%/style/Earth/img/bull.png
@@ -164,10 +172,8 @@
%%WWWDIR%%/style/Earth/img/feed.png
%%WWWDIR%%/style/Earth/img/help.png
%%WWWDIR%%/style/Earth/img/index.html
-%%WWWDIR%%/style/Earth/img/main_end.png
-%%WWWDIR%%/style/Earth/img/main_top.png
%%WWWDIR%%/style/Earth/index.html
-%%WWWDIR%%/style/Earth.css
+%%WWWDIR%%/style/Fire.css
%%WWWDIR%%/style/Fire/base_admin.css
%%WWWDIR%%/style/Fire/img/asterisk.png
%%WWWDIR%%/style/Fire/img/bull.png
@@ -177,15 +183,13 @@
%%WWWDIR%%/style/Fire/img/feed.png
%%WWWDIR%%/style/Fire/img/help.png
%%WWWDIR%%/style/Fire/img/index.html
-%%WWWDIR%%/style/Fire/img/main_end.png
-%%WWWDIR%%/style/Fire/img/main_top.png
%%WWWDIR%%/style/Fire/index.html
-%%WWWDIR%%/style/Fire.css
%%WWWDIR%%/style/Lithium.css
%%WWWDIR%%/style/Mercury.css
%%WWWDIR%%/style/Oxygen.css
%%WWWDIR%%/style/Radium.css
%%WWWDIR%%/style/Sulfur.css
+%%WWWDIR%%/style/Technetium.css
%%WWWDIR%%/style/Technetium/bg.png
%%WWWDIR%%/style/Technetium/dark-shade.png
%%WWWDIR%%/style/Technetium/darker-shade.png
@@ -200,36 +204,13 @@
%%WWWDIR%%/style/Technetium/index.html
%%WWWDIR%%/style/Technetium/inv-shade.png
%%WWWDIR%%/style/Technetium/light-shade.png
-%%WWWDIR%%/style/Technetium.css
%%WWWDIR%%/style/imports/base_admin.css
%%WWWDIR%%/style/imports/index.html
-%%WWWDIR%%/style/imports/minmax.js
%%WWWDIR%%/style/index.html
%%WWWDIR%%/userlist.php
%%WWWDIR%%/viewforum.php
%%WWWDIR%%/viewtopic.php
-@dirrm %%WWWDIR%%/cache
-@dirrm %%WWWDIR%%/img/avatars
-@dirrm %%WWWDIR%%/img/smilies
-@dirrm %%WWWDIR%%/img
-@dirrm %%WWWDIR%%/include/dblayer
-@dirrm %%WWWDIR%%/include/template
-@dirrm %%WWWDIR%%/include/utf8/mbstring
-@dirrm %%WWWDIR%%/include/utf8/native
-@dirrm %%WWWDIR%%/include/utf8/utils
-@dirrm %%WWWDIR%%/include/utf8
-@dirrm %%WWWDIR%%/include
-@dirrm %%WWWDIR%%/lang/English/mail_templates
-@dirrm %%WWWDIR%%/lang/English
-@dirrm %%WWWDIR%%/lang
-@dirrm %%WWWDIR%%/plugins
-@dirrm %%WWWDIR%%/style/Air/img
-@dirrm %%WWWDIR%%/style/Air
-@dirrm %%WWWDIR%%/style/Earth/img
-@dirrm %%WWWDIR%%/style/Earth
-@dirrm %%WWWDIR%%/style/Fire/img
-@dirrm %%WWWDIR%%/style/Fire
-@dirrm %%WWWDIR%%/style/Technetium
-@dirrm %%WWWDIR%%/style/imports
-@dirrm %%WWWDIR%%/style
-@dirrm %%WWWDIR%%
+@mode 777
+@dir %%WWWDIR%%/cache
+@dir %%WWWDIR%%/img/avatars
+@mode