aboutsummaryrefslogtreecommitdiffstats
path: root/www/fluxcms/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-05-08 18:02:13 +0800
committerale <ale@FreeBSD.org>2006-05-08 18:02:13 +0800
commit4457d9861dc45285f48d472b19d6e0427e531d84 (patch)
tree5cc29f890216e88ff1b5a06ed164ff7df067a118 /www/fluxcms/Makefile
parent58c1a0211f97a7df0626f8e239d30e27447330eb (diff)
downloadfreebsd-ports-gnome-4457d9861dc45285f48d472b19d6e0427e531d84.tar.gz
freebsd-ports-gnome-4457d9861dc45285f48d472b19d6e0427e531d84.tar.zst
freebsd-ports-gnome-4457d9861dc45285f48d472b19d6e0427e531d84.zip
Fix package build.
Approved by: maintainer
Diffstat (limited to 'www/fluxcms/Makefile')
-rw-r--r--www/fluxcms/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/www/fluxcms/Makefile b/www/fluxcms/Makefile
index d50268b47b7a..bb91fb7a7315 100644
--- a/www/fluxcms/Makefile
+++ b/www/fluxcms/Makefile
@@ -21,18 +21,17 @@ INSTALLDIR= ${PREFIX}/${FLUXCMSDIR}
PLIST_SUB= INSTALLDIR=${FLUXCMSDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-OPTIONS= GD "Use GD support instead of ImageMagick" off \
+OPTIONS= GD "Use GD support instead of ImageMagick" on \
TIDY "Configure with tidy support" off
USE_PHP= dom xml simplexml iconv mysql xsl session pcre
+BROKEN_WITH_PHP= 4
DEFAULT_PHP_VER= 5
.include <bsd.port.pre.mk>
-WITH_PHP5= yes
-
-.if defined(WITH_GD)
+.if !defined(WITHOUT_GD)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
.else
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/${imagick_DEPENDS}