aboutsummaryrefslogtreecommitdiffstats
path: root/www/fluxcms/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-26 22:47:18 +0800
committerpav <pav@FreeBSD.org>2006-06-26 22:47:18 +0800
commit4c4eec15463c67bec5f9d38baa2a9f44e3a0424e (patch)
treeba40f952331b04069ad4d3f0ec849e32c1271209 /www/fluxcms/Makefile
parent1494deaf57b8e72112c09d3530431d8309bb706f (diff)
downloadfreebsd-ports-gnome-4c4eec15463c67bec5f9d38baa2a9f44e3a0424e.tar.gz
freebsd-ports-gnome-4c4eec15463c67bec5f9d38baa2a9f44e3a0424e.tar.zst
freebsd-ports-gnome-4c4eec15463c67bec5f9d38baa2a9f44e3a0424e.zip
- Update to 1.4.0
PR: ports/99474 Submitted by: Beat Gatzi <beat@chruetertee.ch> (maintainer)
Diffstat (limited to 'www/fluxcms/Makefile')
-rw-r--r--www/fluxcms/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/fluxcms/Makefile b/www/fluxcms/Makefile
index bb91fb7a7315..91a4354b2cfd 100644
--- a/www/fluxcms/Makefile
+++ b/www/fluxcms/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fluxcms
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4.0
CATEGORIES= www
MASTER_SITES= http://bitflux.org/download/ \
http://www.chruetertee.ch/files/download/
@@ -20,17 +20,22 @@ FLUXCMSDIR= www/fluxcms
INSTALLDIR= ${PREFIX}/${FLUXCMSDIR}
PLIST_SUB= INSTALLDIR=${FLUXCMSDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+SUB_FILES= pkg-deinstall pkg-message
+SUB_LIST= INSTALLDIR=${FLUXCMSDIR}
OPTIONS= GD "Use GD support instead of ImageMagick" on \
TIDY "Configure with tidy support" off
USE_PHP= dom xml simplexml iconv mysql xsl session pcre
-BROKEN_WITH_PHP= 4
DEFAULT_PHP_VER= 5
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+
.include <bsd.port.pre.mk>
+BROKEN_WITH_PHP= 4
+
.if !defined(WITHOUT_GD)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
.else
@@ -47,6 +52,6 @@ do-install:
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${INSTALLDIR}
post-install:
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>