aboutsummaryrefslogtreecommitdiffstats
path: root/www/frontpage
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-02-25 00:23:50 +0800
committerleeym <leeym@FreeBSD.org>2003-02-25 00:23:50 +0800
commite6460e2c5b44834e4aa4853bf6d3f3d127696456 (patch)
treecefb0fc37de33460e0d32686a9cd68e0d2ee10f4 /www/frontpage
parent4e25e12d82cff92266052a27dacc6b14d76ee5d1 (diff)
downloadfreebsd-ports-gnome-e6460e2c5b44834e4aa4853bf6d3f3d127696456.tar.gz
freebsd-ports-gnome-e6460e2c5b44834e4aa4853bf6d3f3d127696456.tar.zst
freebsd-ports-gnome-e6460e2c5b44834e4aa4853bf6d3f3d127696456.zip
- fix the file permission problem by running the ${FPSETPERM} script
- remove the extra files created by the ${REINPLACE_CMD} PR: 48555 Submitted by: Scot W. Hetzel <hetzels@westbend.net>
Diffstat (limited to 'www/frontpage')
-rw-r--r--www/frontpage/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/frontpage/Makefile b/www/frontpage/Makefile
index 1711c7602e4f..f72a2d5c2b28 100644
--- a/www/frontpage/Makefile
+++ b/www/frontpage/Makefile
@@ -117,6 +117,9 @@ do-install:
@${ECHO_MSG} "===> Untaring FrontPage Extensions to ${PREFIX}"
@(cd ${PREFIX} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} ${EXTRACT_AFTER_ARGS})
@${REINPLACE_CMD} -e 's:IMAGESDIR:../images/:g' ${PREFIX}/${FPCSS}
+ @if [ -f ${PREFIX}/${FPCSS} ]; then \
+ ${RM} ${PREFIX}/${FPCSS}.bak ; \
+ fi
@${RM} ${PREFIX}/${FPHTTPD}/httpd
@${MKDIR} ${MOD_FPDOCDIR}
@${CP} ${PREFIX}/${README} ${MOD_FPDOCDIR}/index.html
@@ -125,5 +128,6 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
+ @${PREFIX}/${FPSETPERM}
.include <bsd.port.post.mk>