aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon2/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-06-17 03:03:10 +0800
committermarcus <marcus@FreeBSD.org>2002-06-17 03:03:10 +0800
commit275673ba5e814377b8f5315752d7d2af44cbbf7c (patch)
tree224f441443f57ef5bbdadec8ee2644255da5ef18 /www/galeon2/Makefile
parentceb8893cf306504ff17661c979c2fd36227bb93a (diff)
downloadfreebsd-ports-gnome-275673ba5e814377b8f5315752d7d2af44cbbf7c.tar.gz
freebsd-ports-gnome-275673ba5e814377b8f5315752d7d2af44cbbf7c.tar.zst
freebsd-ports-gnome-275673ba5e814377b8f5315752d7d2af44cbbf7c.zip
Fix build on -CURRENT.
Diffstat (limited to 'www/galeon2/Makefile')
-rw-r--r--www/galeon2/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 6eb3a1f4cda5..b59b68ed1067 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -41,6 +41,14 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= galeon.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+# Galeon does not build correctly in -CURRENT if -Werror is passed
+# to the compiler.
+CONFIGURE_ARGS+= --disable-werror
+.endif
+
post-extract:
.if !defined(WITH_FULL_MOZILLA)
@${ECHO_MSG}
@@ -69,4 +77,4 @@ post-configure:
pre-install:
@-${X11BASE}/bin/gconftool --shutdown
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>