aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-05-17 06:02:15 +0800
committermarcus <marcus@FreeBSD.org>2003-05-17 06:02:15 +0800
commite6af296e789153a0359d7f231f1df1fe96064680 (patch)
tree667e7fd710359e4f2ef74e0466f5fb87343f3b32 /www/galeon2
parentfc0a45df0032289eb9fcb55ed421f2b9332ceb74 (diff)
downloadfreebsd-ports-gnome-e6af296e789153a0359d7f231f1df1fe96064680.tar.gz
freebsd-ports-gnome-e6af296e789153a0359d7f231f1df1fe96064680.tar.zst
freebsd-ports-gnome-e6af296e789153a0359d7f231f1df1fe96064680.zip
Update for Mozilla 1.4b.
Diffstat (limited to 'www/galeon2')
-rw-r--r--www/galeon2/Makefile2
-rw-r--r--www/galeon2/files/patch-mozilla_GaleonWrapper.cpp28
2 files changed, 29 insertions, 1 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 6cd3a88857d8..ca1b992d978f 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -31,7 +31,7 @@ HEADERS_SUFX=
.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
-MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.4a"
+MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
.else
MOZILLA= mozilla-gtk2
HEADERS_SUFX=
diff --git a/www/galeon2/files/patch-mozilla_GaleonWrapper.cpp b/www/galeon2/files/patch-mozilla_GaleonWrapper.cpp
new file mode 100644
index 000000000000..dca228aec48f
--- /dev/null
+++ b/www/galeon2/files/patch-mozilla_GaleonWrapper.cpp
@@ -0,0 +1,28 @@
+--- mozilla/GaleonWrapper.cpp.orig Fri May 16 17:21:37 2003
++++ mozilla/GaleonWrapper.cpp Fri May 16 17:23:41 2003
+@@ -70,7 +70,11 @@
+ #include "nsCWebBrowser.h"
+ #include "nsReadableUtils.h"
+ #include "nsUnicharUtils.h"
++#if MOZILLA_SNAPSHOT > 7
++#include "nsIDOMNSDocument.h"
++#else
+ #include "nsIDOMNSHTMLDocument.h"
++#endif
+ #include "nsIDOMHTMLDocument.h"
+ #include "nsIDOMHTMLCollection.h"
+ #include "nsIDOMHTMLElement.h"
+@@ -1106,8 +1110,13 @@
+ result = GetDOMDocument (getter_AddRefs(DOMDocument));
+ if (NS_FAILED(result) || !DOMDocument) return NS_ERROR_FAILURE;
+
++#if MOZILLA_SNAPSHOT > 7
++ nsCOMPtr<nsIDOMNSDocument> doc = do_QueryInterface(DOMDocument);
++ if (!doc) return NS_ERROR_FAILURE;
++#else
+ nsCOMPtr<nsIDOMNSHTMLDocument> doc = do_QueryInterface(DOMDocument);
+ if(!doc) return NS_ERROR_FAILURE;
++#endif
+
+ nsAutoString value;
+ doc->GetLastModified(value);