aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon2
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-08-17 17:49:02 +0800
committersobomax <sobomax@FreeBSD.org>2000-08-17 17:49:02 +0800
commitaefee2de28a933e044904059debb663177a2c15c (patch)
tree36fc1443de987a8ce45cfdf33a68465ab2ad3dfb /www/galeon2
parent6656bd852556f636e78355d5bdfa642844151536 (diff)
downloadfreebsd-ports-gnome-aefee2de28a933e044904059debb663177a2c15c.tar.gz
freebsd-ports-gnome-aefee2de28a933e044904059debb663177a2c15c.tar.zst
freebsd-ports-gnome-aefee2de28a933e044904059debb663177a2c15c.zip
Update to 0.7.2.
Now the port uses mozilla-embedded port for html rendering by default, but you can override it by defining WITH_FULL_MOZILLA (for example if you are planning to use both mozilla and galeon on the same machine). WARNING! This port requires M17 to work.
Diffstat (limited to 'www/galeon2')
-rw-r--r--www/galeon2/Makefile26
-rw-r--r--www/galeon2/distinfo2
-rw-r--r--www/galeon2/files/patch-ab8
-rw-r--r--www/galeon2/pkg-plist16
4 files changed, 42 insertions, 10 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 3ab307e5bfe8..5e99d7ed99b0 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -6,18 +6,24 @@
#
PORTNAME= galeon
-PORTVERSION= 0.7.1
+PORTVERSION= 0.7.2
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/mozilla:build
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/${MOZILLA}:build
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
glade.4:${PORTSDIR}/devel/libglade
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
- mozilla:${PORTSDIR}/www/mozilla
+ ${X11BASE}/lib/${MOZILLA}:${PORTSDIR}/www/${MOZILLA}
+
+.if !defined(WITH_FULL_MOZILLA)
+MOZILLA= mozilla-embedded
+.else
+MOZILLA= mozilla
+.endif
USE_X_PREFIX= yes
USE_NEWGCC= yes
@@ -36,6 +42,15 @@ CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITH_FULL_MOZILLA)
+post-extract:
+ @${ECHO_MSG}
+ @${ECHO_MSG} " By default the port uses mozilla-embedded for html rendering, but if you are"
+ @${ECHO_MSG} " planning to use both Mozilla and Galeon you can instruct it to use mozilla by"
+ @${ECHO_MSG} " defining \"WITH_FULL_MOZILLA\"."
+ @${ECHO_MSG}
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -44,9 +59,10 @@ pre-patch:
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
s|-lpthread|-pthread|g'
-post-patch:
+post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/src/galeon
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%MOZILLA%%|${MOZILLA}|g' ${WRKSRC}/src/galeon
.include <bsd.port.mk>
diff --git a/www/galeon2/distinfo b/www/galeon2/distinfo
index c322cb1767a4..f3bb1d653e04 100644
--- a/www/galeon2/distinfo
+++ b/www/galeon2/distinfo
@@ -1 +1 @@
-MD5 (galeon-0.7.1.tar.gz) = d21f940a1fcf385d3dc2a512a7435ed7
+MD5 (galeon-0.7.2.tar.gz) = 279e2123cd747eaf8097ab1d901ac510
diff --git a/www/galeon2/files/patch-ab b/www/galeon2/files/patch-ab
index 157f691ec8ab..10e821dbedd6 100644
--- a/www/galeon2/files/patch-ab
+++ b/www/galeon2/files/patch-ab
@@ -14,10 +14,10 @@
- MOZILLA_HOME=/usr/local/mozilla
-elif [ -f /usr/lib/mozilla/libgtkembedmoz.so ]; then
- MOZILLA_HOME=/usr/lib/mozilla
-+elif [ -f %%LOCALBASE%%/lib/mozilla/libgtkembedmoz.so ]; then
-+ MOZILLA_HOME=%%LOCALBASE%%/lib/mozilla
-+elif [ -f %%X11BASE%%/lib/mozilla/libgtkembedmoz.so ]; then
-+ MOZILLA_HOME=%%X11BASE%%/lib/mozilla
++elif [ -f %%LOCALBASE%%/lib/%%MOZILLA%%/libgtkembedmoz.so ]; then
++ MOZILLA_HOME=%%LOCALBASE%%/lib/%%MOZILLA%%
++elif [ -f %%X11BASE%%/lib/%%MOZILLA%%/libgtkembedmoz.so ]; then
++ MOZILLA_HOME=%%X11BASE%%/lib/%%MOZILLA%%
else
echo "Cannot find mozilla installation directory. Please set MOZILLA_FIVE_HOME to your mozilla directory"
exit
diff --git a/www/galeon2/pkg-plist b/www/galeon2/pkg-plist
index a180f4ef4bd8..26ee789ce5ca 100644
--- a/www/galeon2/pkg-plist
+++ b/www/galeon2/pkg-plist
@@ -1,6 +1,20 @@
bin/galeon
bin/galeon-bin
share/gnome/apps/Internet/galeon.desktop
+share/gnome/galeon/anim_01.png
+share/gnome/galeon/anim_02.png
+share/gnome/galeon/anim_03.png
+share/gnome/galeon/anim_04.png
+share/gnome/galeon/anim_05.png
+share/gnome/galeon/anim_06.png
+share/gnome/galeon/anim_07.png
+share/gnome/galeon/anim_08.png
+share/gnome/galeon/anim_09.png
+share/gnome/galeon/anim_10.png
+share/gnome/galeon/anim_11.png
+share/gnome/galeon/anim_12.png
+share/gnome/galeon/anim_13.png
+share/gnome/galeon/anim_14.png
share/gnome/galeon/bookmarks.xml
share/gnome/galeon/galeon.glade
share/gnome/galeon/logo.png
@@ -8,6 +22,7 @@ share/gnome/galeon/preferences.xml
share/gnome/pixmaps/galeon.png
share/gnome/pixmaps/galeon/logo.jpg
share/locale/da/LC_MESSAGES/galeon.mo
+share/locale/de/LC_MESSAGES/galeon.mo
share/locale/es/LC_MESSAGES/galeon.mo
share/locale/et/LC_MESSAGES/galeon.mo
share/locale/fr/LC_MESSAGES/galeon.mo
@@ -15,5 +30,6 @@ share/locale/it/LC_MESSAGES/galeon.mo
share/locale/ko/LC_MESSAGES/galeon.mo
share/locale/ru/LC_MESSAGES/galeon.mo
share/locale/sv/LC_MESSAGES/galeon.mo
+share/locale/tr/LC_MESSAGES/galeon.mo
@dirrm share/gnome/pixmaps/galeon
@dirrm share/gnome/galeon
s'>-14/+19 * - Update to 4.9miwi2013-03-025-94/+81 * - Update to 2.31miwi2013-03-023-23/+20 * - Update to 0.4dmiwi2013-03-022-11/+17 * - Update to 0.90miwi2013-03-0211-400/+87 * - Update to 0.7.5miwi2013-03-022-9/+5 * - Add patch to fix buildswills2013-02-262-5/+11 * Add new ports science/fvcom and science/fvcom-mpi:makc2013-02-218-0/+230 * - Update to 4.6miwi2013-02-107-370/+291 * - Update to 3.4.0miwi2013-02-092-3/+5 * - Update to 1.1.44tota2013-02-092-5/+4 * - Fix build with clangmiwi2013-02-074-3/+35 * japanese/vflib||2013-02-06|Has expired: No more public distfilesbapt2013-02-0612-218/+0 * - Fix breakage in the DYNAMIC-enabled ports triggered by the recentpgj2013-02-061-1/+1 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-045-18/+7 * Bump PORTREVISON after devel/py-sip and devel/qscintilla2 update.makc2013-02-042-1/+2 * - Fix all cases of 'No newline at end of file' in ports treeak2013-02-011-1/+1 * Chase boost updatebapt2013-01-311-2/+2 * Update to 0.011.tobez2013-01-292-8/+4 * - Update to 1.2.2swills2013-01-222-3/+3 * - Chase lib version changes from ilmbase and OpenEXR updatesswills2013-01-181-1/+1 * - Update to 1.75.01wen2013-01-153-92/+211 * - Update to 0.2-6tota2013-01-082-4/+3 * Update to 3.0.0.maho2013-01-083-6/+8 * update to 1.0.0.maho2013-01-082-7/+6 * * Update to 3.0.0.maho2013-01-084-175/+8 * Fix recent build on tinderbox. Somehow "sc_PsiCCSD_T.3" is notmaho2013-01-082-7/+10 * Host some documens in local-distfiles. Somehow documents are dissapeared.maho2013-01-071-1/+2 * - Remove wrong dependency on gtkglareabapt2013-01-071-7/+4 * - Add an explicit dependency on gettext to fix build on system where everythingbapt2013-01-071-5/+4 * - remove an obsoleted dependency on py-numarray;thierry2013-01-051-6/+5 * update the R base ports to 2.15.2 and adjust dependent portsbf2013-01-0510-47/+18 * Upgrade GDL to 0.9.3.thierry2013-01-0212-67/+140 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-304-0/+12 * - Fix build with clangbeech2012-12-246-42/+106 * - Update to 4.2.8.araujo2012-12-209-136/+85 * - Update The Glorious Glasgow Haskell Compiler to version 7.4.2pgj2012-12-202-7/+3 * Update to 5.4.7eadler2012-12-192-11/+7 * Cleanup supporting perl version 5.8 and 5.10,az2012-12-171-8/+1 * - Update to version 3.3.0 [1]pawel2012-12-174-12/+21 * Convert to new option frameworkbapt2012-12-131-9/+6 * - Update to 5.4.7beech2012-12-133-5/+5 * - Bump port after ImageMagick updatebeech2012-12-121-2/+2 * science/openbabel:makc2012-12-1115-304/+209 * Update PCRE to 8.32mm2012-12-111-0/+1 * Fix HDF5 description.thierry2012-12-111-1/+1 * Decommissioning java 1.5 (EOLed since October 2009):bapt2012-12-104-19/+7 * Revert Chris Petrik's ports to the pool. Thank you for all your work so far,...eadler2012-12-101-1/+1 * - Update to 1.7 [1]culot2012-12-092-9/+5 * Switch to OptionsNG.thierry2012-12-081-15/+16 * - Trim Makefile headerswen2012-12-071-6/+2 * - Use a space after "Created by:", not a tabrene2012-12-061-2/+2 * - Convert to optionsNGrene2012-12-061-16/+13 * - Trim Makefile headerswen2012-12-061-6/+2 * - Update to 0.99.24bdrewery2012-12-054-17/+17 * - Reset MAINTAINER due to unrecoverable bouncezi2012-12-051-1/+1 * - add patch to fix build with latest boost 1.48rm2012-12-013-12/+20 * - Update to version 3.07sperber2012-12-0113-964/+112 * - Update to version 0.7.4sperber2012-12-013-16/+16 * Upgrade to 3.6.1.1.thierry2012-11-274-101/+74 * - Update to 1.0.2bdrewery2012-11-272-5/+5 * Upgrade to 2012.02.05.thierry2012-11-235-14/+90 * Update to version 2.30pawel2012-11-114-218/+370 * - update to 3.3.4 (old version isn't fetchable anymore)gahr2012-11-084-427/+635 * Fix dep.demon2012-11-081-1/+1 * Add missing depends.demon2012-11-081-1/+2 * - forgot to remove a file in the last update.stephen2012-11-081-11/+0 * - Update to 2.2.1.stephen2012-11-083-74/+54 * - Update to 1.1.40tota2012-11-073-9/+5 * Hand over port to new volunteer.eadler2012-11-021-1/+1 * Drop maintainership per requesteadler2012-11-021-5/+2 * - Update to 1.2.1swills2012-10-213-113/+34 * scikit-learn is a Python module integrating classic machine learningdemon2012-10-195-0/+883 * - update to 0.11.0rm2012-10-172-17/+14 * - Update to 0.13culot2012-10-163-5/+9 * Update to 2.0.6makc2012-10-115-16/+25 * - Update to 2.15.1.0wen2012-10-112-9/+4 * - Trim Makefile headerswen2012-10-101-6/+2 * - Trim Makefile headerswen2012-10-109-45/+9 * - Update to 0.7.0wen2012-10-103-11/+9 * Force numerous ports that fail to build with clang over to instead alwayslinimon2012-10-101-0/+1 * - Remove automatic dependency to SuiteSparse; use OPTIONS insteadmva2012-10-071-4/+10 * - Update to 1.0.1wen2012-10-072-9/+5 * - convert to optionsNGflo2012-10-071-31/+26 * - Fix header to proper formatbdrewery2012-10-011-1/+1 * - Reassign to the heap at maintainer's requesttabthorpe2012-10-012-12/+4 * - Update to 1.3.1sunpoet2012-09-302-8/+4 * - Pass maintainership to submitterbdrewery2012-09-291-6/+2 * - Update to 0.12culot2012-09-263-11/+19 * - Reassign to the heap at maintainer's requesttabthorpe2012-09-241-6/+2 * Remove QT_COMPONENTS - Qt 3 ports don't use itmakc2012-09-201-1/+0 * - Update to 0.7.0wen2012-09-183-25/+50 * - Update to 0.7.0wen2012-09-173-79/+20 * - Update to 0.7.0wen2012-09-174-10/+10 * - Update to 0.7.0wen2012-09-153-4/+4 * - Update to 0.7.0wen2012-09-153-4/+4 * - Update to 1.6-1tota2012-09-152-4/+3 * Fix typo.linimon2012-09-141-2/+2 * - Move libxul 1.9.2 to www/libxul19beat2012-09-111-1/+1 * - Update to 0.7.0wen2012-09-093-4/+6 * Fix on FreeBSD-7.x.thierry2012-09-081-0/+29 * Mark as broken on powerpc.linimon2012-09-081-1/+7 * - Update to 0.7.0wen2012-09-043-4/+10 * - Update to 0.7.1wen2012-09-043-13/+47 * - Update to 1.4.0wen2012-09-043-30/+153 * Add a PORTSCOUT tag so only stable releases get found.kwm2012-08-201-0/+2 * - Update to 3.2ak2012-08-094-42/+386 * - Update to 2.0.8culot2012-08-063-16/+3 * Switch from libglut to freeglut and retire libglut. Libglut hasn't beenkwm2012-08-055-4/+5 * Fix typos and make small modifications in COMMENT (according to Porter'scs2012-08-033-3/+3 * - Teach the Haskell Cabal ports to use the new options frameworkpgj2012-08-031-0/+1 * - Fix typos in COMMENTcs2012-08-021-1/+1 * - Convert my ports to new options frameworkmakc2012-07-271-6/+8 * - Update to 1.7.0.swills2012-07-253-234/+15 * Update to version 2.0.18 [1]zeising2012-07-216-11/+25 * Update to version 1.5.1 [1]zeising2012-07-215-9/+23 * Update to 3.12.0cs2012-07-182-3/+3 * - Update to 0.3-10tota2012-07-162-4/+3 * Complete the removal of ics to silence warnings on pointyhat.linimon2012-07-121-1/+0 * add math/metis4 to math/Makefile; update math/metis to 5.0.2; add appropriatebf2012-07-092-5/+5 * Remove ICS, which is no more a component of Code_Saturne.thierry2012-07-074-319/+0 * Upgrade Code_Saturne to 2.0.thierry2012-07-0719-1036/+1028 * Upgrade to 3.1.3-4.thierry2012-07-0711-58/+340 * MEI stands for Mathematical Expression Interpreter.thierry2012-07-076-0/+73 * - Update to 0.11wen2012-07-012-5/+5 * - Remove SITE_PERL from *_DEPENDSaz2012-06-301-2/+2 * - Update to 1.1.36tota2012-06-302-4/+3 * - Remove SITE_PERL from *_DEPENDSaz2012-06-2918-140/+140 * - Detect eigen2 by checking for .pc file, not min. port version.avilla2012-06-273-3/+3 * update math/R to 2.15.1, switch to the new options format, andbf2012-06-279-9/+9 * - reset MAINTAINERdinoex2012-06-262-2/+2 * s/X11BASE/LOCALBASE/, or equivalent.dougb2012-06-251-5/+5 * - Update to 1.3.0sunpoet2012-06-242-20/+18 * - Convert to new options frameworksunpoet2012-06-191-14/+11 * - Update to 1.5.5sunpoet2012-06-152-6/+6 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-154-6/+4 * - update to 5.4.5.beech2012-06-14