aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-02-18 02:45:36 +0800
committermarcus <marcus@FreeBSD.org>2003-02-18 02:45:36 +0800
commit682233e6020aceaefbefd61deecb99b52894db73 (patch)
tree0a443f73ed90d4b1c7bd4e11dad09db752bddf0d /www/galeon
parent0eba6be4ed0357025e076d2058703c4e6128abe9 (diff)
downloadfreebsd-ports-gnome-682233e6020aceaefbefd61deecb99b52894db73.tar.gz
freebsd-ports-gnome-682233e6020aceaefbefd61deecb99b52894db73.tar.zst
freebsd-ports-gnome-682233e6020aceaefbefd61deecb99b52894db73.zip
Add a conditional dependency on nautilus.
Submitted by: Olivier Tharan <olive@oban.frmug.org>
Diffstat (limited to 'www/galeon')
-rw-r--r--www/galeon/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 348250a244f2..9e0f4e506a6b 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -52,7 +52,6 @@ USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUFX}" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}" \
- --enable-nautilus-view \
${MOZ_CONFIGURE_ARGS}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_REENTRANT ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -62,6 +61,15 @@ MAN1= galeon.1
.include <bsd.port.pre.mk>
+.if exists(${X11BASE}/lib/libnautilus.so.0)
+WITH_NAUTILUS= yes
+.endif
+
+.if defined(WITH_NAUTILUS)
+LIB_DEPENDS+= nautilus.0:${PORTSDIR}/x11-fm/nautilus
+CONFIGURE_ARGS+= --enable-nautilus-view
+.endif
+
.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.