aboutsummaryrefslogtreecommitdiffstats
path: root/www/gallery3/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-02-08 15:55:28 +0800
committerleeym <leeym@FreeBSD.org>2005-02-08 15:55:28 +0800
commit87f08cdef580c12b0238690d901d157fc1c6e27c (patch)
tree5af7761b74a806389dad091317d67c06716efbbe /www/gallery3/Makefile
parent283439ac5f379127de9a04df31f72d481fcd45aa (diff)
downloadfreebsd-ports-gnome-87f08cdef580c12b0238690d901d157fc1c6e27c.tar.gz
freebsd-ports-gnome-87f08cdef580c12b0238690d901d157fc1c6e27c.tar.zst
freebsd-ports-gnome-87f08cdef580c12b0238690d901d157fc1c6e27c.zip
- Update to 1.4.4.6
- This fixes a few potential cross-site scripting bugs which was intended to be fixed in 1.4.4.5 - Apply PORTDOCS - Add some minor fixes about COMMENT and DISTNAME PR: 77247 Submitted by: Alex Varju <freebsd-ports at varju.ca>
Diffstat (limited to 'www/gallery3/Makefile')
-rw-r--r--www/gallery3/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/gallery3/Makefile b/www/gallery3/Makefile
index 6556999ad89f..5685dd51688b 100644
--- a/www/gallery3/Makefile
+++ b/www/gallery3/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= gallery
-PORTVERSION= 1.4.4.5
+PORTVERSION= 1.4.4.6
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.5$/-pl5/}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}-pl${PORTVERSION:E}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${LANGPACKS}
DIST_SUBDIR= gallery
MAINTAINER= freebsd-ports@varju.ca
-COMMENT= Gallery is a slick web based photo album written using PHP
+COMMENT= A slick web based photo album written using PHP
RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm \
jhead:${PORTSDIR}/graphics/jhead \
@@ -73,8 +73,8 @@ PLIST_SUB= NLS="@comment "
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-DOCFILES= AUTHORS ChangeLog README
-EXCEPTFILES= ${DOCFILES} LICENSE.txt
+PORTDOCS= AUTHORS ChangeLog README
+EXCEPTFILES= ${PORTDOCS} LICENSE.txt
CPIOARGS= --quiet -pdum -R
PLIST_SUB+= GALLERYDIR=${GALLERYDIR}
@@ -111,7 +111,7 @@ do-install:
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
- @ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCFILES} ${DOCSDIR}
+ @ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.if !defined(BATCH)
@ ${CAT} ${PKGMESSAGE}