aboutsummaryrefslogtreecommitdiffstats
path: root/www/gatling
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-28 06:46:55 +0800
committerkrion <krion@FreeBSD.org>2004-02-28 06:46:55 +0800
commit24acb55d3991092559ecd9eb41f6eaa3f8d97a70 (patch)
treec586609ec5389e9df9715de06c0475a000c4f7b0 /www/gatling
parent210c19f4d7ee6e078b44fc7497823ef3563aa559 (diff)
downloadfreebsd-ports-gnome-24acb55d3991092559ecd9eb41f6eaa3f8d97a70.tar.gz
freebsd-ports-gnome-24acb55d3991092559ecd9eb41f6eaa3f8d97a70.tar.zst
freebsd-ports-gnome-24acb55d3991092559ecd9eb41f6eaa3f8d97a70.zip
- Utilize NOPORTDOCS
- Fix a filedescriptor leak that occured when doing HTTP pipelining - Bump PORTREVISION PR: ports/63452 Submitted by: maintainer
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile3
-rw-r--r--www/gatling/files/patch-gatling.c22
2 files changed, 25 insertions, 0 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index c05eb234f7a6..ad00e8ab8dce 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gatling
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= www benchmarks
MASTER_SITES= http://dl.fefe.de/
@@ -23,8 +24,10 @@ MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lowfat" \
bin= dl gatling
examples= run-gatling
examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
+.if !defined(NOPORTDOCS)
PORTDOCS= CHANGES README README.ftp README.http README.performance \
README.prefetch
+.endif
OPTIONS= BENCHMARKS "Install system benchmark programs" on
diff --git a/www/gatling/files/patch-gatling.c b/www/gatling/files/patch-gatling.c
new file mode 100644
index 000000000000..833a5b36f75a
--- /dev/null
+++ b/www/gatling/files/patch-gatling.c
@@ -0,0 +1,22 @@
+! Fix a filedescriptor leak. This change requires libowfat-0.18
+! Obtained from gatling cvs
+--- gatling.c.orig Fri Feb 27 16:09:53 2004
++++ gatling.c Fri Feb 27 16:13:28 2004
+@@ -876,7 +876,7 @@
+ c+=fmt_str(c,"\r\n\r\n");
+ iob_addbuf_free(&h->iob,h->hdrbuf,c - h->hdrbuf);
+ if (!head)
+- iob_addfile(&h->iob,fd,range_first,range_last-range_first);
++ iob_addfile_close(&h->iob,fd,range_first,range_last-range_first);
+ if (logging) {
+ if (h->hdrbuf[9]=='3') {
+ buffer_puts(buffer_1,head?"HEAD/304 ":"GET/304 ");
+@@ -1034,7 +1034,7 @@
+ range_last=ss.st_size;
+ range_first=h->ftp_rest; h->ftp_rest=0;
+ if (range_first>range_last) range_first=range_last;
+- iob_addfile(&b->iob,b->filefd,range_first,range_last-range_first);
++ iob_addfile_close(&b->iob,b->filefd,range_first,range_last-range_first);
+ if (logging) {
+ buffer_putulonglong(buffer_1,range_last-range_first);
+ buffer_putspace(buffer_1);